1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Site Crashed, Server Error

Discussion in 'Troubleshooting and Problems' started by leslie dow, Apr 22, 2015.

  1. leslie dow

    leslie dow Active Member

    Hi all
    I am hoping that someone has seen this. I have a site that crashed yesterday and when restored from backups, crashed again within an hour of restoring from a backup that was made about 12 hours before the crash. I am certain that nobody was in the Admin Panel at the time and there were no changes or upgrades to addons in the past week.

    The site is inaccessible including the Admin Panel. I've included below the error that I see when I try to login to the admin panel.

    NOTE: I have a bug report with the XF people and don't want to duplicate that but I am hoping that someone in the community has seen this and has some idea of what happened.


    The only additional information is that there may be an association between this and ArrowChat, but I am not certain.

    Server Error
    Mysqli prepare error: Unknown column 'user.user_id' in 'where clause'

    1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
    2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
    3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
    4. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 753
    5. Zend_Db_Adapter_Abstract->fetchRow() in XenForo/Model/User.php at line 427
    6. XenForo_Model_User->getUserById() in XenForo/Session.php at line 337
    7. XenForo_Session::getPublicSession() in XenForo/ControllerAdmin/Login.php at line 7
    8. XenForo_ControllerAdmin_Login->actionForm() in XenForo/FrontController.php at line 347
    9. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    10. XenForo_FrontController->run() in /home/savvyauthors/public_html/Community/admin.php at line 13
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    I have replied to your ticket.
     
  3. Mike

    Mike XenForo Developer Staff Member

    I would suspect server issues more than anything -- for example, the server's disk being full, leading to corruption of MySQL data.
     
  4. leslie dow

    leslie dow Active Member

    Thanks mike, my ISp is saying there are no server issues, they are saying its application. I'm going to disable all the addons once they restore it again
    Best
    Leslie
     

Share This Page