1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Signup Registration Error...

Discussion in 'Troubleshooting and Problems' started by usAdultAds, May 1, 2013.

  1. usAdultAds

    usAdultAds Active Member

    It is always useful when you have members that can help you with letting
    you know what works, and what does not work. I just got notification that
    a new member was trying to register on the forum, and got the following error:

    forum: http://www.adulthaven.com
    Fatal error: Maximum execution time of 30 seconds exceeded in
    /home/abcoutle/public_html/adulthaven.com/library/XenForo/Model/User.php on line 330

    I guess this also explains why I have gotten no bot signups either....

  2. Brogan

    Brogan XenForo Moderator Staff Member

    Do you have any add-ons installed?

    Have you made any changes to the registration script?
    14DH01 likes this.
  3. usAdultAds

    usAdultAds Active Member

    normally I would not change script or template without some type of clear documentation, but in this
    case I have not started to do anything yet, so no, I have not changed or made any edits to any files/templates, etc...

    I do have some addons; I can see where this is going :) I will start with any registation/spam mods,
    and work my way down until there is no more addons to blame; If it is addon, then someone hasnt
    been updating their addons, just goes to show how quickly addons can be outdated, bad mojo....

    I just tried it myself, and got a different url:
    Fatal error: Maximum execution time of 30 seconds exceeded in
    /home/abcoutle/public_html/adulthaven.com/library/XenForo/Application.php on line 366

    Moving on to check addons....

  4. usAdultAds

    usAdultAds Active Member

    It looks like it was addon related, before I take the time to test each one out,
    maybe someone already knows if any of these addons affect registration...

    Addon Install & Update
    Enforce Post Rules
    Live Updates
    MobileRead Reported Posts
    New User Conversation
    Sitemap for XenForo
    XF Arcade
    Tag Me
    Xen Tag

    Anything come to mind?
  5. 14DH01

    14DH01 Active Member

    I give you the code up in the config.php​
    just after "<php?" in a new line, add:​
    //$config ['enableListeners'] =  false ;
    Detach the two "/ /" it will activate stopping add-on.​
    it will be like this:​
    $config ['enableListeners'] =  false ;
    Do not forget to add the two / / to put the addon on walking​
    made an entry test without add-on​
    So you see if it's an addon that is causing the problem​
  6. usAdultAds

    usAdultAds Active Member

    what does this do? disable all addons?
    right now they are all disabled, and signup is working,
    so I assume it is one of the addons causing the conflict.

    14DH01 likes this.
  7. 14DH01

    14DH01 Active Member

    :rolleyes: Yes (y)
    In your admin panel off one by one(add-on) to locate the one that breaks the inscriptions.​
    Once the add-on locate, download it to a floppy and would put it under the wheel of a big truck :D
  8. usAdultAds

    usAdultAds Active Member

    whats a floppy? (j/k)
    I used to drive a big truck.
    I wouldnt want to wreck the truck....

    14DH01 likes this.
  9. 14DH01

    14DH01 Active Member

    it was a joke because of the "add-on" which bugged your "XenForo":(
    I drop my support here​
  10. usAdultAds

    usAdultAds Active Member

    You did not offend me....

    I wish there was an easier process to do this...I only have a mere 11 addons...
    Just think if I was a much bigger forum, 50-100 addons, it would make for a bad day....

    I think I will go make some pancakes....
    It has to be morning somewhere in the world....

    14DH01 likes this.
  11. Ernest L. Defoe

    Ernest L. Defoe Well-Known Member

    Best thing you can do is enable them one at a time and see which one messes up registration. Then just not enable that addon.
    14DH01 likes this.
  12. 14DH01

    14DH01 Active Member

    11 add-on that is not much you have to test by disabling one by one
    and make the entry test and go to the next add-on.
    :rolleyes: you need to find the one that causes your conflict ;)

    Yes Ernest L. Defoe ;)
  13. usAdultAds

    usAdultAds Active Member

    that is what I will have to end up doing; if it was a simple reload, then it may not take so long, but
    for the fact that I have to bounce back and forth to attempt registration each time, at least
    I have only 11, but the thing is addons are out of date, and discontinued all the time, if there
    were some type of report that gives you some indication of why something has failed, it surely
    would help rather then having to go through each addon until you find the cause....

    I guess if there was such a report option, then it would have been out by now...

    For the time being, ill get though it...

  14. Ernest L. Defoe

    Ernest L. Defoe Well-Known Member

    Have you tried looking in the server error logs under Tools in your AdminCP? That may also help you pinpoint your culprit addon.
    14DH01 likes this.
  15. usAdultAds

    usAdultAds Active Member

    There is nothing of interest on the server logs; However, XF log seems to be somewhat interesting:

    Addon causing registration conflict:
    New User Welcome Conversation

  16. Xyphien

    Xyphien Active Member

    So I just had the same problem, after going through all the plugins, I found out that this plugin did the same thing to me.

Share This Page