• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Shared IPs

CarpCharacin

Well-known member
#1
My IP was on spam blacklists, so I asked my host to change it to one that wasn't on blacklists, and they did. AFter they did that, it started showing up that all users online were coming from the IP of my site and that all posts were coming from that IP. If I go to shared IPs on any user that has been active since the host tweaked it, it shows myself and my staff and all of the other users who have been active. The host says that they have disabled nginx for my account and that I should waight 34 hours, and it hasn't been 34 hours, but this is bothering me and I want to get it fixed.
 

Jake B.

Well-known member
#2
My IP was on spam blacklists, so I asked my host to change it to one that wasn't on blacklists, and they did. AFter they did that, it started showing up that all users online were coming from the IP of my site and that all posts were coming from that IP. If I go to shared IPs on any user that has been active since the host tweaked it, it shows myself and my staff and all of the other users who have been active. The host says that they have disabled nginx for my account and that I should waight 34 hours, and it hasn't been 34 hours, but this is bothering me and I want to get it fixed.
Sounds like you'll need to contact your host to fix it. Or maybe add this to your config.php file:

PHP:
$_SERVER['REMOTE_ADDR'] = $_SERVER['HTTP_X_FORWARDED_FOR'];
 

CarpCharacin

Well-known member
#3
I added that and I think it worked worked. My real IP is showing up, but the IP of the google bot is the IP of the sight. Is there any way to fix the shared IP logs and the post IPs? It is really bugging me.
 

Brogan

XenForo moderator
Staff member
#4
You would need to remove the data - you can do that in the Logging Options by setting the number of days to 1 now, then set it back to 365 tomorrow (once the log has been cleared by the clean up cron - or you can run the cron manually).
 

CarpCharacin

Well-known member
#5
You would need to remove the data - you can do that in the Logging Options by setting the number of days to 1 now, then set it back to 365 tomorrow (once the log has been cleared by the clean up cron - or you can run the cron manually).
Where is logging options? So I can change it back to 365 after I run the clean up cron?
 

CarpCharacin

Well-known member
#7
I did it, but the shared IPs from yesterday and today are still there. Is there any way to remove them now, or should I just wait until tomorrow?
 

Tracy Perry

Well-known member
#11

CarpCharacin

Well-known member
#13
There is an error log and it was just when I tried to create an additional tab in notable members. Nothing from the IP. I thold the host that I fixed the problem and to keep nginx, but I haven't heard back from them. I didn't know that they were using it as a reverse proxy, but I asked them. What should I do?
 

CarpCharacin

Well-known member
#15
They said that nginx is no longer running on my account, but I removed the code that I had put in the config.php file and the real IPs stopped showing. I put the code back, and the real IPs show up.
 

Tracy Perry

Well-known member
#20
They asked if I wanted to change servers. Should I?
That's up to you. If nginx is working (and you don't have cPanel actually controlling Apache as the back end server) the I'd leave it as nginx is a higher performing HTTP server than Apache. BUT, it's very unlikely if you have cPanel that you are only using nginx. Almost all cPanel add-ons I've found use nginx as a reverse proxy and not the primary proxy.