set the registration page as the homepage

James

Well-known member
It should work presuming your full node_name is just 123. What is it set at in the ACP?
 

James

Well-known member
your params array is wrong

as posted in this thread http://xenforo.com/community/threads/library-set-your-own-route-controller-as-homepage.10156/

Rich (BB code):
$config = new Zend_Config(array('routePrefix' => 'pages',
'controllerClass' => 'XenForo_ControllerPublic_Page',
'params' => array('node_name' => 'lectus-pretium-consequat'),
));[/php]
and you're using


'params' => array('123' => 'lectus-pretium-consequat'),
He rectified that here: http://xenforo.com/community/threads/set-the-registration-page-as-the-homepage.53559/#post-579788
 

time

Active member
@James
My page


123.jpg

Here is the code I use
Code:
<?php
 
  class CustomIndex_addon6
  {
      public static function initDependencies(XenForo_Dependencies_Abstract $dependencies, array $data)
      {
          if (!$dependencies instanceof XenForo_Dependencies_Public)
          {
              return;
          }

    $config = new Zend_Config(array('routePrefix' => 'pages','controllerClass' => 'XenForo_ControllerPublic_Page','params' => array('node_name' => '123'),
));
    GeekPoint_CustomIndex_Helper::setDefaultRoute($config, $data);
}
  }
 
  ?>
 

James

Well-known member
Hmm, odd.

Have you tried doing it with a more unique node name instead of 123? Perhaps renaming it to something containing a word.

Alternatively, try using the URL portion 123_a as the node_name and see if that works.

I believe @Brogan did this, maybe he can provide some insight.
 
Last edited:
Top