1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Server error

Discussion in 'Troubleshooting and Problems' started by dutchbb, Nov 10, 2015.

Tags:
  1. dutchbb

    dutchbb Well-Known Member

    Server Error

    Mysqli statement execute error : Lock wait timeout exceeded; try restarting transaction

    Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
    Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
    Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 661
    Zend_Db_Adapter_Abstract->delete() in XenForo/DataWriter.php at line 1825
    XenForo_DataWriter->_delete() in XenForo/DataWriter.php at line 1778
    XenForo_DataWriter->delete() in XenForo/Model/Post.php at line 1210
    XenForo_Model_Post->deletePost() in XenForo/ControllerPublic/Post.php at line 351
    XenForo_ControllerPublic_Post->actionDelete() in XenForo/FrontController.php at line 351
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    XenForo_FrontController->run() in /var/www/forum.bodybuilding.nl/public_html/index.php at line 13

    Error Info:

    Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Lock wait timeout exceeded; try restarting transaction - library/Zend/Db/Statement/Mysqli.php:214
    Generated By: ****, 1 minute ago

    Stack Trace
    #0 /var/www/forum.****.nl/public_html/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
    #1 /var/www/forum.****.nl/public_html/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
    #2 /var/www/forum.****.nl/public_html/library/Zend/Db/Adapter/Abstract.php(661): Zend_Db_Adapter_Abstract->query('DELETE FROM `xf...')
    #3 /var/www/forum.****.nl/public_html/library/XenForo/DataWriter.php(1825): Zend_Db_Adapter_Abstract->delete('xf_post', 'post_id = 93188...')
    #4 /var/www/forum.****.nl/public_html/library/XenForo/DataWriter.php(1778): XenForo_DataWriter->_delete()
    #5 /var/www/forum.****.nl/public_html/library/XenForo/Model/Post.php(1210): XenForo_DataWriter->delete()
    #6 /var/www/forum.****.nl/public_html/library/XenForo/ControllerPublic/Post.php(351): XenForo_Model_Post->deletePost(9318827, 'hard', Array, Array)
    #7 /var/www/forum.****.nl/public_html/library/XenForo/FrontController.php(351): XenForo_ControllerPublic_Post->actionDelete()
    #8 /var/www/forum.****.nl/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #9 /var/www/forum.****.nl/public_html/index.php(13): XenForo_FrontController->run()
    #10 {main}

    Request State:

    array(3) {
    ["url"] => string(49) "http://forum.****.nl/posts/9318827/delete"
    ["_GET"] => array(1) {
    ["/posts/9318827/delete"] => string(0) ""
    }
    ["_POST"] => array(4) {
    ["hard_delete"] => string(1) "1"
    ["_xfConfirm"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["redirect"] => string(23) "topics/tapatalk.390415/"
    }
    }




    Is there a way to prevent this from happening again? I've experienced it a few times now.
     
  2. dutchbb

    dutchbb Well-Known Member

    So, do I need to increase "Lock wait timeout" or is there any underlying problem causing slowdowns like this (network or software problem?)
     

Share This Page