• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Server Error when editing a thread title

#1
When I tried to edit the title of a thread from Thread Tools>Edit Thread I got this. Any ideas?

It's an old thread from a converted database (from phpbb3). It might have even been created in the days of PHP-Nuke (yuck!) then migrated to phpbb3, then finally Xenforo.

Title change was not completed.

Server Error

Undefined index: post_id
  1. XenForo_Application::handlePhpError() in XenForo/Search/DataHandler/Post.php at line 33
  2. XenForo_Search_DataHandler_Post->_insertIntoIndex() in XenForo/Search/DataHandler/Abstract.php at line 227
  3. XenForo_Search_DataHandler_Abstract->insertIntoIndex() in XenForo/DataWriter/Discussion.php at line 612
  4. XenForo_DataWriter_Discussion->_updateSearchIndexTitle() in XenForo/DataWriter/Discussion.php at line 539
  5. XenForo_DataWriter_Discussion->_indexForSearch() in XenForo/DataWriter/Discussion.php at line 380
  6. XenForo_DataWriter_Discussion->_postSave() in XenForo/DataWriter.php at line 1385
  7. XenForo_DataWriter->save() in XenForo/ControllerPublic/Thread.php at line 773
  8. XenForo_ControllerPublic_Thread->actionSave() in XenForo/FrontController.php at line 310
  9. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
  10. XenForo_FrontController->run() in /home/-------/public_html/-------/index.php at line 13
 

Mike

XenForo developer
Staff member
#2
That's not an error I've seen before, and it's strange for there not to be a post_id (though I have a guess as to why, but I don't know why no one else has run into it before). If you submit a ticket with FTP and admin details, I'll see if I can track it down.