• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Server Error on installation :s

#1
I get this far "/install/index.php?install/step/2b"then i get an error:
Server Error

Server Error

Mysqli statement execute error : Got error 28 from storage engine
  1. Zend_Db_Statement_Mysqli->_execute()in/home/habloud2/public_html/community/library/Zend/Db/Statement.phpat line292
  2. Zend_Db_Statement->execute()in/home/habloud2/public_html/community/library/Zend/Db/Adapter/Abstract.phpat line468
  3. Zend_Db_Adapter_Abstract->query()in/home/habloud2/public_html/community/library/XenForo/Model.phpat line218
  4. XenForo_Model->fetchAllKeyed()in/home/habloud2/public_html/community/library/XenForo/Model/StyleProperty.phpat line79
  5. XenForo_Model_StyleProperty->getStylePropertiesInStyles()in/home/habloud2/public_html/community/library/XenForo/Model/StyleProperty.phpat line130
  6. XenForo_Model_StyleProperty->getEffectiveStylePropertiesInStyle()in/home/habloud2/public_html/community/library/XenForo/Model/StyleProperty.phpat line2141
  7. XenForo_Model_StyleProperty->importStylePropertiesFromArray()in/home/habloud2/public_html/community/library/XenForo/Model/StyleProperty.phpat line2127
  8. XenForo_Model_StyleProperty->importStylePropertyXml()in/home/habloud2/public_html/community/library/XenForo/Model/StyleProperty.phpat line2060
  9. XenForo_Model_StyleProperty->importStylePropertyDevelopmentXml()in/home/habloud2/public_html/community/library/XenForo/CacheRebuilder/ImportMasterData.phpat line42
  10. XenForo_CacheRebuilder_ImportMasterData->rebuild()in/home/habloud2/public_html/community/library/XenForo/ControllerHelper/CacheRebuild.phpat line26
  11. XenForo_ControllerHelper_CacheRebuild->rebuildCache()in/home/habloud2/public_html/community/library/XenForo/Install/Controller/Install.phpat line243
  12. XenForo_Install_Controller_Install->actionStep2b()in/home/habloud2/public_html/community/library/XenForo/FrontController.phpat line303
  13. XenForo_FrontController->dispatch()in/home/habloud2/public_html/community/library/XenForo/FrontController.phpat line132
  14. XenForo_FrontController->run()in/home/habloud2/public_html/community/install/index.phpat line17
Is this an error in Xen or my host and how can i fix it?

How can i be classed as a member when im a customer aswell.
 

Jake Bunce

XenForo moderator
Staff member
#2
#4
i now got a server error:


Server Error


Server Error

Mysqli statement execute error : Duplicate entry '1-generated_by' for key 'language_id_title'
  1. Zend_Db_Statement_Mysqli->_execute()in/home/habloud2/public_html/community/library/Zend/Db/Statement.phpat line292
  2. Zend_Db_Statement->execute()in/home/habloud2/public_html/community/library/Zend/Db/Adapter/Abstract.phpat line468
  3. Zend_Db_Adapter_Abstract->query()in/home/habloud2/public_html/community/library/Zend/Db/Adapter/Abstract.phpat line546
  4. Zend_Db_Adapter_Abstract->insert()in/home/habloud2/public_html/community/library/XenForo/Model/Phrase.phpat line899
  5. XenForo_Model_Phrase->insertPhraseMapForLanguages()in/home/habloud2/public_html/community/library/XenForo/CacheRebuilder/Phrase.phpat line37
  6. XenForo_CacheRebuilder_Phrase->rebuild()in/home/habloud2/public_html/community/library/XenForo/ControllerHelper/CacheRebuild.phpat line26
  7. XenForo_ControllerHelper_CacheRebuild->rebuildCache()in/home/habloud2/public_html/community/library/XenForo/Install/Controller/Install.phpat line243
  8. XenForo_Install_Controller_Install->actionStep2b()in/home/habloud2/public_html/community/library/XenForo/FrontController.phpat line303
  9. XenForo_FrontController->dispatch()in/home/habloud2/public_html/community/library/XenForo/FrontController.phpat line132
  10. XenForo_FrontController->run()in/home/habloud2/public_html/community/install/index.phpat line17
This seems harder to install then VBulletin :l
 
#7
i keep getting:

Rebuilding...



An error occurred or the request was stopped.

i used a new database aswell :l

starting to think i wasted money :(

now i got error:


Server Error


Server Error

Mysqli statement execute error : Prepared statement needs to be re-prepared
  1. Zend_Db_Statement_Mysqli->_execute() in /home/habloud2/public_html/community/library/Zend/Db/Statement.php at line 292
  2. Zend_Db_Statement->execute() in /home/habloud2/public_html/community/library/Zend/Db/Adapter/Abstract.php at line 468
  3. Zend_Db_Adapter_Abstract->query() in /home/habloud2/public_html/community/library/XenForo/Model.php at line 218
  4. XenForo_Model->fetchAllKeyed() in /home/habloud2/public_html/community/library/XenForo/Model/Language.php at line 46
  5. XenForo_Model_Language->getAllLanguages() in /home/habloud2/public_html/community/library/XenForo/Model/Phrase.php at line 918
  6. XenForo_Model_Phrase->buildPhraseMapForLanguageTree() in /home/habloud2/public_html/community/library/XenForo/CacheRebuilder/Phrase.php at line 37
  7. XenForo_CacheRebuilder_Phrase->rebuild() in /home/habloud2/public_html/community/library/XenForo/ControllerHelper/CacheRebuild.php at line 26
  8. XenForo_ControllerHelper_CacheRebuild->rebuildCache() in /home/habloud2/public_html/community/library/XenForo/Install/Controller/Install.php at line 243
  9. XenForo_Install_Controller_Install->actionStep2b() in /home/habloud2/public_html/community/library/XenForo/FrontController.php at line 303
  10. XenForo_FrontController->dispatch() in /home/habloud2/public_html/community/library/XenForo/FrontController.php at line 132
  11. XenForo_FrontController->run() in /home/habloud2/public_html/community/install/index.php at line 17
 
#11
Architecture​
x86_64​
MySQL version​
5.0.91-community​
Path to sendmail​
/usr/sbin/sendmail​
Apache version​
2.2.17​
PHP version​
5.2.14​
cPanel Pro​
1.0 (RC1)​
 

Blandt

Well-known member
#16
could that be why it's not installing?
In my opinion you should change hosting and not even bother ... because obviously even if your version of MySQL will run xenforo, it is 4-5 years out... which tells me your server is pretty old .. and your hoster needs to go :D

Hostgator is pretty reasonable and very well maintained servers
 
#17
ok i tried the checker:
XenForo 1.0 System Requirements Test

Requirements Met

Your server meets all of XenForo's PHP requirements.
XenForo also requires MySQL 5.0 or newer. Please manually check that you meet this requirement.