1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Serious problems since 1.1.1

Discussion in 'Troubleshooting and Problems' started by gwinans, Jan 5, 2012.

  1. gwinans

    gwinans Active Member

    I get this even on clean installs in an nginx config that has worked on 3 other installs.

    Failed to get controller response and reroute to error handler (XenForo_ControllerPublic_Error::actionErrorNotFound)

    This is when clicking on:

    Terms and rules
    Contact us

    It changes each install. Previous install, /members/ wasn't working, throwing the same error.

    What's going on here? I have a feeling this is why XenPorta is also failing to install.
  2. Fuhrmann

    Fuhrmann Well-Known Member

    Can you post the complete server error log about this problem?

    Admin CP -> Tools -> Server Error Log
  3. gwinans

    gwinans Active Member

    It's not creating a server error log for those pages. The last error log it created was for my attempted install of XenPorta. I even have debug mode enabled, not really giving me much to go on.
  4. Fuhrmann

    Fuhrmann Well-Known Member

  5. gwinans

    gwinans Active Member

    I wish it was as easy as that. This is a dead-clean install. We got into adding a few forums and started noticing little things were broken for no discernible reason.
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    The error is fairly clear. There is no controller response. The question is why.

    My first guess is an addon. If you can get into the Admin CP then try disabling your addons with the check boxes on the Home page. Or you can add this line to your library/config.php file:

    $config['enableListeners'] = 0;
    If that doesn't fix it then it might be bad files. Run a file check:

    Admin CP -> Tools -> File Health Check

    If any problems are reported then you need to upload the original files again.
  7. gwinans

    gwinans Active Member

    Clean install, no addons. File Health Check says all is well. The above also didn't fix it.

    I ended up going back to 1.1.0 and all is well.. I'm stumped.
  8. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Does your server use APC caching? Try flushing the cache. Maybe it's a problem with file caching. But I am really just guessing at this point.
  9. Brogan

    Brogan XenForo Moderator Staff Member

    Have you tried downloading the .zip package again?
    Even though the file health check reports all OK, it's worth a try.

    Other than that, it may be worth opening a ticket so Mike can take a look at it.

Share This Page