1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Send Mail - Server error

Discussion in 'Troubleshooting and Problems' started by tommydamic68, Sep 29, 2013.

  1. tommydamic68

    tommydamic68 Well-Known Member

    I have this error in my server log -twice.

    Code:
    Zend_Mail_Transport_Exception: Unable to send mail. mail() [<a href='function.mail'>function.mail</a>]: Could not execute mail delivery program '/usr/sbin/sendmail -t -i' - library/Zend/Mail/Transport/Sendmail.php:137
    Generated By: Unknown Account, Yesterday at 10:35 PM
    Stack Trace
    #0 /home1/admin/public_html/community/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Sendmail->_sendMail()
    #1 /home1/admin/public_html/community/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
    #2 /home1/admin/public_html/community/library/XenForo/Model/MailQueue.php(62): Zend_Mail->send(Object(Zend_Mail_Transport_Sendmail))
    #3 /home1/admin/public_html/community/library/XenForo/Deferred/MailQueue.php(10): XenForo_Model_MailQueue->runMailQueue(9.99999690056)
    #4 /home1/admin/public_html/community/library/XenForo/Model/Deferred.php(208): XenForo_Deferred_MailQueue->execute(Array, Array, 9.99999690056, '')
    #5 /home1/admin/public_html/community/library/XenForo/Model/Deferred.php(331): XenForo_Model_Deferred->runDeferred(Array, 9.99999690056, '', false)
    #6 /home1/admin/public_html/community/library/XenForo/Model/Deferred.php(284): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
    #7 /home1/admin/public_html/community/deferred.php(18): XenForo_Model_Deferred->run(false)
    #8 {main}
    Request State
    array(3) {
      ["url"] => string(48) "http://www.mysite.com/community/deferred.php"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(4) {
        ["_xfRequestUri"] => string(42) "/community/conversations/re-bambino.15817/"
        ["_xfNoRedirect"] => string(1) "1"
        ["_xfToken"] => string(8) "********"
        ["_xfResponseType"] => string(4) "json"
      }
    }
    
     
  2. Mike

    Mike XenForo Developer Staff Member

    If it's happening consistently or happens again at a separate time, then you'll want to contact your host. The error indicates that the PHP mail() function isn't configured correctly or some other server issue.

    You may be able to switch to sending mail via SMTP instead.
     
  3. FabioCesar

    FabioCesar Member

    I have this error

    Zend_Mail_Protocol_Exception: Temporary local problem - please try later - library/Zend/Mail/Protocol/Abstract.php:431
    Gerado Por: Conta Desconhecida, 8 minutos atrĂ¡s

    #0 /home/xxx/public_html/library/Zend/Mail/Protocol/Smtp.php(289): Zend_Mail_Protocol_Abstract->_expect(Array, 300)
    #1 /home/xxx/public_html/library/Zend/Mail/Transport/Smtp.php(211): Zend_Mail_Protocol_Smtp->rcpt('fagundesbr@hotm...')
    #2 /home/x/public_html/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Smtp->_sendMail()
    #3 /home/x/public_html/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
    #4 /home/x/public_html/library/XenForo/Model/MailQueue.php(62): Zend_Mail->send(Object(Zend_Mail_Transport_Smtp))
    #5 /home/x/public_html/library/XenForo/Deferred/MailQueue.php(10): XenForo_Model_MailQueue->runMailQueue(9.999998093)
    #6 /home/x/public_html/library/XenForo/Model/Deferred.php(208): XenForo_Deferred_MailQueue->execute(Array, Array, 9.999998093, '')
    #7 /home/x/public_html/library/XenForo/Model/Deferred.php(331): XenForo_Model_Deferred->runDeferred(Array, 9.999998093, '', false)
    #8 /home/x/public_html/library/XenForo/Model/Deferred.php(284): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
    #9 /home/x/public_html/deferred.php(18): XenForo_Model_Deferred->run(false)
    #10 {main}
    Solicitar Estado
    array(3) {
    ["url"] => string(38) "http://www.x.com./deferred.php"
    ["_GET"] => array(0) {
    }
    ["_POST"] => array(3) {
    ["_xfRequestUri"] => string(51) "/threads/xxxxxx.xxx/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
    }
    }
     
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

    The connection to your SMTP server failed, if it happens consistently, you should contact your provider.
     

Share This Page