1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Select text to quote

Discussion in 'Troubleshooting and Problems' started by shorepower, Aug 27, 2014.

  1. shorepower

    shorepower Active Member

    After installation of release candidate 1 the select text to quote have stopped working on mobile devices at our test site. When selecting text the option to quote or add to multi-quote do no longer appear, only the standard copy function in Android. Have tried two different devices, one tablet and one phone (Android 4.0.2 and 4.4.3) with Chrome browser.

    Tried customized and standard Xenforo style. Cleaned all caches (Xenforo and browsers) checked for outdated templates.

    Function works on standard PC as designed and did work on mobile devices with Beta 3.

    Tried to re-create problem on xenforo.com but function work from both mobile devices so I do not report this as a bug.

    Any suggestions on steps I can take to isolate/resolve the problem?

    Edit: Did installation of 1.4.0 RC1 as an upgrade of installed Beta 3
    Last edited: Aug 27, 2014
  2. Mike

    Mike XenForo Developer Staff Member

    Are there any JS errors in the console? I would also try on the default style with all add-ons disabled. There were some changes to this in RC1, though nothing significant.
  3. shorepower

    shorepower Active Member

    Took a while to learn how to get into the console on a phone but now I learned more on Android testing that I thought I ever would know :)

    I disabled the three add-ons I have installed, used the default style first with no change. Entered the phone into development mode and turned on the console remotely and suddenly the function worked. It now works with occasional errors, selected text not being quoted even if selected and sometimes the the option to quote do no appear as stated above. Going out of development mode, the function continues to work, but with the same, slightly "unstable" behavior.

    There is no JS errors listed in the console and I can see the quotes etc being processed. When not processed, no functional calls are recorded.

    Enabled the add-ons and moved to customized style and the select text to quote continues in the same way, slightly "unstable" Asked a Iphone-user to test and he has similar problems.

    Will consider a complete reinstall of the server and see if that helps. Any other ideas? Are there performance areas I need to check on the server side or is it primarily front-end dependent?

    Thanks for the support here.
  4. AndyB

    AndyB Well-Known Member

    It would be best if you created a test forum with a default new installation of XenForo 1.4 RC1.

Share This Page