• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

See Node tree - Error

ioneti

Active member
#1
Hi, in ACP when i go to see node tree i have this error:

Mysqli statement execute error : Can't create/write to file '/tmp/#sql_35a6_0.MYD' (Errcode: 17)

  1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
  2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
  3. Zend_Db_Adapter_Abstract->query() in XenForo/Model.php at line 219
  4. XenForo_Model->fetchAllKeyed() in XenForo/Model/Moderator.php at line 97
  5. XenForo_Model_Moderator->getContentModerators() in XenForo/ControllerAdmin/Node.php at line 26
  6. XenForo_ControllerAdmin_Node->actionIndex() in XenForo/FrontController.php at line 337
  7. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  8. XenForo_FrontController->run() in /home/forocsgo/public_html/admin.php at line 13

sorry if this is not the site to post it.
 

Amaury

Well-known member
#2
Looks like it's a problem with your site specifically rather than a software bug.

Have you checked your server error logs?
 

ioneti

Active member
#3
yes. this:

Code:
Info del error
Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Can't create/write to file '/tmp/#sql_35a6_0.MYD' (Errcode: 17) - library/Zend/Db/Statement/Mysqli.php:214
Generado por: i0n, Hace 1 minuto
Seguimiento

#0 /home/forocsgo/public_html/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
#1 /home/forocsgo/public_html/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
#2 /home/forocsgo/public_html/library/XenForo/Model.php(219): Zend_Db_Adapter_Abstract->query('?????SELECT mod...', Array, 2)
#3 /home/forocsgo/public_html/library/XenForo/Model/Moderator.php(97): XenForo_Model->fetchAllKeyed('?????SELECT mod...', 'moderator_id')
#4 /home/forocsgo/public_html/library/XenForo/ControllerAdmin/Node.php(26): XenForo_Model_Moderator->getContentModerators(Array)
#5 /home/forocsgo/public_html/library/XenForo/FrontController.php(337): XenForo_ControllerAdmin_Node->actionIndex()
#6 /home/forocsgo/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#7 /home/forocsgo/public_html/admin.php(13): XenForo_FrontController->run()
#8 {main}

Estado de la solicitud

array(3) {
  ["url"] => string(39) "http://www.xiglo21.com/admin.php?nodes/"
  ["_GET"] => array(1) {
    ["nodes/"] => string(0) ""
  }
  ["_POST"] => array(0) {
  }
 

Amaury

Well-known member
#4
yes. this:

Code:
Info del error
Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Can't create/write to file '/tmp/#sql_35a6_0.MYD' (Errcode: 17) - library/Zend/Db/Statement/Mysqli.php:214
Generado por: i0n, Hace 1 minuto
Seguimiento

#0 /home/forocsgo/public_html/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
#1 /home/forocsgo/public_html/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
#2 /home/forocsgo/public_html/library/XenForo/Model.php(219): Zend_Db_Adapter_Abstract->query('?????SELECT mod...', Array, 2)
#3 /home/forocsgo/public_html/library/XenForo/Model/Moderator.php(97): XenForo_Model->fetchAllKeyed('?????SELECT mod...', 'moderator_id')
#4 /home/forocsgo/public_html/library/XenForo/ControllerAdmin/Node.php(26): XenForo_Model_Moderator->getContentModerators(Array)
#5 /home/forocsgo/public_html/library/XenForo/FrontController.php(337): XenForo_ControllerAdmin_Node->actionIndex()
#6 /home/forocsgo/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#7 /home/forocsgo/public_html/admin.php(13): XenForo_FrontController->run()
#8 {main}

Estado de la solicitud

array(3) {
  ["url"] => string(39) "http://www.xiglo21.com/admin.php?nodes/"
  ["_GET"] => array(1) {
    ["nodes/"] => string(0) ""
  }
  ["_POST"] => array(0) {
  }
Have you tried disabling your resources via config.php to see if the problem persists afterward?
 

ioneti

Active member
#9
This is a server issue related to mySQL. You should contact your host for help.

The error has been for a private forum. I think an error with xenporta...

Now, i want to create the same node-forum and when i click to accept an error shows again

Mysqli statement execute error : Duplicate entry '18' for key 'PRIMARY'
  1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
  2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
  3. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 574
  4. Zend_Db_Adapter_Abstract->insert() in XenForo/DataWriter.php at line 1612
  5. XenForo_DataWriter->_insert() in XenForo/DataWriter.php at line 1601
  6. XenForo_DataWriter->_save() in XenForo/DataWriter.php at line 1393
  7. XenForo_DataWriter->save() in XenForo/ControllerAdmin/Forum.php at line 122
  8. XenForo_ControllerAdmin_Forum->actionSave() in XenForo/FrontController.php at line 337
  9. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  10. XenForo_FrontController->run() in /home/forocsgo/public_html/admin.php at line 13
 

Amaury

Well-known member
#10
The error has been for a private forum. I think an error with xenporta...
Do you get the same issue with XenPorta disabled? If not, then you should post in the XenPorta thread to receive support on it if the issue does indeed lie within XenPorta.
 

Mike

XenForo developer
Staff member
#15
With the first error, the second error makes me wonder if there's potential data corruption here. The error you're now receiving indicates inconsistent data. If you have a recent backup, that might be the safest option.

If not, be aware that you may run into various other errors. On the whole, you'll just need to try to create the record until it goes through (the number in the error should go up each time).
 

ioneti

Active member
#16
With the first error, the second error makes me wonder if there's potential data corruption here. The error you're now receiving indicates inconsistent data. If you have a recent backup, that might be the safest option.

If not, be aware that you may run into various other errors. On the whole, you'll just need to try to create the record until it goes through (the number in the error should go up each time).

When i created some new forums some dates of the previous forum shows on.

example:

i created a forum. i select name and when i pulse D it shows me Donation, the problem is that Donation is a forum of my previous XENFORO forum that i deleted.

I deleted the XENFORO forum and the database...

Maybe it is the error i thinks, or not? what can i do?
 

ioneti

Active member
#17
I dont explain very good but help please:

2 weeks ago my xenforo forum was x.com. I deleted it and create new xenforo forum call y.com.

I deleted the database but other example:

When i go to create a thread and i pulse S, it shows me threads of x.com!!!!!

is possible that it is the error?

thanks!!
 

ioneti

Active member
#19
My forum its new...i reset host and i go to install all again...

Thanks again!

One more question Jeremy, i want to auto backup my database.

My host has cron works...what i have to do?