1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

RM 1.2 Security error on update

Discussion in 'Resource Manager Support' started by jauburn, Nov 17, 2015.

  1. jauburn

    jauburn Well-Known Member

    Why am I getting this error message when trying to update a resource item?

    security.png
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Have you had the page open for a long time before attempting to submit the update?

    Try opening the page in a new tab and trying again.
     
    jauburn likes this.
  3. Chris D

    Chris D XenForo Developer Staff Member

    What size is the file?

    If it's a large file and it exceeds the post_max_size value then it can present itself in this way.
     
    jauburn likes this.
  4. jauburn

    jauburn Well-Known Member

    I closed all browser windows and tried again. Still the same error.

    The file size is 6.8 MB.

    http://poetrycircle.com/forum/resources/sisyphus-leaves.69/

    Is that too big?
     
  5. Brogan

    Brogan XenForo Moderator Staff Member

    Hmm, your post_max_size is 8M and your upload_max_filesize is 64M so it should be fine.

    You could try increasing the post_max_size just in case.
    You can do that by editing the php.ini file, or by adding this to the .htaccess file:
    Code:
    php_value post_max_size 16M
     
  6. jauburn

    jauburn Well-Known Member

    Where in the .htaccess would this go? Here's what I have:

    # Mod_security can interfere with uploading of content such as attachments. If you
    # cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    # SecFilterEngine Off
    # SecFilterScanPOST Off
    #</IfModule>
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    <IfModule mod_rewrite.c>
    RewriteEngine On
    # If you are having problems with the rewrite rules, remove the "#" from the
    # line that begins "RewriteBase" below. You will also have to change the path
    # of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo
    # This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

    You can put it at the bottom.
     
  8. jauburn

    jauburn Well-Known Member

    Well, that broke the forum:

    Not Found
    It looks like nothing was found at this location. Maybe try a search?
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    There's no reason why it should have but you can simply remove it.

    You can try editing the php.ini file instead.
     
  10. jauburn

    jauburn Well-Known Member

    To avoid this kind of thing from happening in the future, is there a good reason to limit the php post max size to 16 MB? How about 32 or 64?
     
  11. Brogan

    Brogan XenForo Moderator Staff Member

    You can set it higher if you wish.
     
  12. jauburn

    jauburn Well-Known Member

    The upload_max_filesize in php is already at 64 MB. Now what?
     
  13. Chris D

    Chris D XenForo Developer Staff Member

    Have you changed the post_max_size in php.ini yet?

    After you make the changes, restart Apache. Verify in phpinfo that the value has taken effect (admin.php?tools/phpinfo)
     
    Last edited: Nov 18, 2015
  14. jauburn

    jauburn Well-Known Member

    I did that and will report back if it works (or not). Thanks.
     

Share This Page