1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Secondary usergroups

Discussion in 'Troubleshooting and Problems' started by Mythotical, Jan 12, 2012.

  1. Mythotical

    Mythotical Well-Known Member

    I don't know what is going on but when I setup upgrades to add to a secondary usergroup, those that made purchases cannot see the forums specified for the usergroup that is set as secondary for them.

    Am I missing something? Did I forget something?

  2. Mythotical

    Mythotical Well-Known Member

    Damnit, wrong forum. That is what I get for not watching where I'm posting.
  3. James

    James Well-Known Member

    It sounds like a permissions issue, have you double-checked that none of the permissions for the user(s) are set to Never?
  4. Robbo

    Robbo Well-Known Member

    Did you set any never permissions? From your description it should work fine. Might be just that you are testing before the cron is run to upgrade people?

    Edit: annnndddd beaten ^
    James likes this.
  5. Mythotical

    Mythotical Well-Known Member

    Nope, nothing set to Never, only through node permissions I have guests and members set to Never but not licensed usergroup.

    Cron has ran, it updated him to the secondary group already.
  6. Mythotical

    Mythotical Well-Known Member

    Ok so it was that the cron didn't run yet. All fixed, thank you both for helping.
    Robbo likes this.
  7. Mythotical

    Mythotical Well-Known Member

    Back to this issue, waited 2 hours, ran the cron and still the user can't see the forums. I have even used the Test Permissions feature to check things. Any suggestions as to the cause?
  8. Brogan

    Brogan XenForo Moderator Staff Member

    Check the permissions of all the user groups the user is a member of.
    Check the user specific permissions, if there are any.
    Ensure the user isn't banned.

    Other than that, it could be a problem related to an add-on.
  9. Mythotical

    Mythotical Well-Known Member

    Well the Member group is primary and that doesn't have permission to view the forums. Could that be the issue?
  10. Brogan

    Brogan XenForo Moderator Staff Member

    If that's the only group he is a member of, yes.
  11. Mythotical

    Mythotical Well-Known Member

    The users primary group is Member and secondary group is Board Member.

    Member is no access while Board Member has access.
  12. Brogan

    Brogan XenForo Moderator Staff Member

    Permissions are cumulative so that should be fine:

    Permission value priority is set in this order: (highest priority first)
    1. Never – this will not grant the permission. This can never be overridden, so should be used sparingly.
    2. Allow – this will grant the permission.
    3. Not Set (No) – this will not grant the permission. This is the lowest priority value; any explicit allow will override this.
    Thus, if a user has not set (no) and allow for a permission, the final value will be allow. The Test Permissions system can help confirm that permissions are set correctly.


    If you like I can take a look to see if I can spot anything obvious.
  13. Mythotical

    Mythotical Well-Known Member

    I don't get it, he says his upgrade is complete and he now is fine but when I test his permissions as his account I see no new forums.

    Is there a specific cron that runs that I missed or does it take that long for Paypal to report back that the payment is good?
  14. Mike

    Mike XenForo Developer Staff Member

    Of course, an add-on can break the user cache rebuild, so if turning off all add-ons and rebuilding the user caches fixes it, that's the culprit.
  15. Mythotical

    Mythotical Well-Known Member

    I have disabled all add-ons and tried it, still nothing. I'll have Brogan take a look.
  16. Brogan

    Brogan XenForo Moderator Staff Member

    ArnyVee likes this.
  17. Mythotical

    Mythotical Well-Known Member

    Oooooh, so I should have that set to Revoke?
  18. Mythotical

    Mythotical Well-Known Member

    Thanks Brogan, I changed it to Revoke and all works now.

Share This Page