1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Search seems 'fuzzy' on this site - can't find what I'm looking for!

Discussion in 'Troubleshooting and Problems' started by Machiavelli, Jun 30, 2012.

  1. Machiavelli

    Machiavelli Member

    My members want a dating area on my site, so I thought I would search xenforo.com to see if I could find any relevant help/suggestions/Add-ons/etc.

    I clicked Search Forums, entered the keyword "dating", and ticked the "Search titles only," and "Display results as threads," options as I only wanted to see threads which specifically had the exact word "dating" in the title.

    However, these are the results I get:


    It seems to be doing a 'fuzzy' search, returning anything which has anything remotely similar to "dating" in the thread title! I'm sure this is great in some scenarios, but for me I just want exact matches.

    Is this correct behaviour? If so, is there a way to turn it off, or an alternative way of finding threads that only have an exact word in the title?

    Thanks. :)
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That is normal because search on this site is configured to use stemming which searches for different forms of the root word (dating, date, dates, etc). The search can be configured differently on your installation, but that is how it is configured on this site.

    I don't know of a way for the end user (you) to turn off stemming in your search. That would be a useful option...
  3. yavuz

    yavuz Well-Known Member

  4. Machiavelli

    Machiavelli Member

    Ah right, thanks for the explanation!
    I ended up just using Google (e.g. "inurl:xenforo.com dating" and similar), but thanks for the suggestion. :)

Share This Page