1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Search Case Sensitive

Discussion in 'Troubleshooting and Problems' started by BamaStangGuy, Jul 26, 2013.

  1. BamaStangGuy

    BamaStangGuy Well-Known Member

    So what would cause search to become case sensitive?

    http://www.bookandreader.com

    searching for wuthering returns 1 result
    searching for Wuthering returns many

    I am using built in xenForo search and have rebuilt caches several times.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. BamaStangGuy

    BamaStangGuy Well-Known Member

  4. AndyB

    AndyB Well-Known Member

    Both search terms returned many for me. I used the Search Threads and Posts search.
     
  5. BamaStangGuy

    BamaStangGuy Well-Known Member

    Why am I getting different results for the exact same term? My members are also seeing this.
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    You are searching via the "Search Everything" tab - I get the same result as you when doing so.

    I'll see what @Mike has to say as I don't know how the various searches are performed.
     
    BamaStangGuy likes this.
  7. BamaStangGuy

    BamaStangGuy Well-Known Member

    I have tried this with Elastic Search and stock search and both produce same result.
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

    I can only assume it's to do with the queries, which will be the same for stock SQL search and ES.
     
  9. Mike

    Mike XenForo Developer Staff Member

    Is this still happening now? I haven't been able to reproduce it yet.
     
  10. BamaStangGuy

    BamaStangGuy Well-Known Member

    I just ran a search again and it seems to be fixed. A cache issue? If so, I don't understand how that could be if we are rebuilding the cache.
     

Share This Page