Browser issue Scrollbar space in ACP when .Touch enabled

Jon W

Well-known member
I think this may be a browser rendering issue (Chrome), but I thought I'd post it just in case anyone can think of a way of fixing it (off the top of my head, I can't think of an easy fix).

When viewing the ACP with the Touch class added (i.e., on touch screens) filter lists are displayed without scrollbars. However, as .Touch is added by Javascript after the browser has rendered the page, it leaves space for the scrollbar after the .Touch has been added.

Is there any way that checking for touch browsers can be done at an earlier stage to stop this from happening?


XenForo developer
Staff member
This seems to display ok for me on Chrome and the standard browser on Android (checked template list). But really, I think it's going to be a browser rendering issue - we don't specify any margins or padding and we disable the overflow on touch browsers.

Jon W

Well-known member
Sorry, should have been more specific -- am using Chrome on a PC with a touch screen. The spacing is the width of the scrollbar that is removed as soon as the Touch class is applied, not any padding or margins.

I usually turn the touch screen settings off now anyway, so not a big deal anyway.