1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 RSS feeds not valid UTF8?

Discussion in 'Troubleshooting and Problems' started by fury, Aug 28, 2013.

  1. fury

    fury Member

    Chrome is reporting to me the following error:

    This page contains the following errors:
    error on line 329 at column 33: Input is not proper UTF-8, indicate encoding ! Bytes: 0x1C 0x43 0x68 0x61
    Below is a rendering of the page up to the first error.

    on the following page: http://racing-forums.com/forums/nascar-chat.8/index.rss

    At this time, line 329 is the following:

          <content:encoded><![CDATA[<b>Dale Jarrett pushing Bristol for All-Star Race:</b> ESPN analyst Dale Jarrett is a public advocate of deeming Bristol Motor Speedway as the new venue for the NASCAR Sprint All-Star Race. Charlotte has been a great venue, and Atlanta that one year, but I think its time that we take it to a short track and let these drivers battle it out, Jarrett said, winner of the 1997 Goodys Headache Powder 500. Short tracks are where every one of these drivers got their start. What better place to...<br />
    Column 33 corresponds to the very beginning of the CDATA, the <

    Any ideas?
  2. Mike

    Mike XenForo Developer Staff Member

  3. fury

    fury Member

    edit: I looked at HEX(message) for the post. Right smack dab in the middle of the post, here are two instances of the 0x1C of which it complains:

    20  1C  43  68  61
    [ ] [?] [C] [h] [a]
    30  30  2E  20  1C  53  68  6F
    [0] [0] [.] [ ] [?] [S] [h] [o]
    An errant paste, perhaps? Did the editor paste or insert some file separator characters? I notice in the source article, there happen to be some double quote marks in there where the "1C" shows up in the database entry. Double quotes are often a source of frustration in my experience - those fancy quote marks often mess things up. Let me try pasting here...

    Last edited: Aug 29, 2013

Share This Page