• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Not a bug RSS Feed

TheRevTastic

Well-known member
#1
Over in my thread I started asking about a problem with the RSS Feed here http://xenforo.com/community/posts/295910/ I have found out it's not just this site but every XF powered forum that the RSS isn't valid for.

Which makes it impossible to import into another forum platform like IP.Board (which I need to do :p).

I haven't tried importing the rss into anything else yet but here are two validation links to the Announcements forum here and the one over on AdminExtra.

AdminExtra: http://validator.w3.org/feed/check....tra.com/forums/read-all-about-it.78/index.rss

Here: http://validator.w3.org/feed/check.....com/community/forums/announcements/index.rss
 

Brogan

XenForo moderator
Staff member
#4
The Google API can be used to add a feed on any page/site.

As I stated anyway, the feed works fine in other readers.
 

Mike

XenForo developer
Staff member
#7
This is an issue with IPB requiring content in the feeds (which isn't required by the spec).

The author validation isn't a significant issue and hasn't caused issues anywhere.
 

Luis

Well-known member
#8
Then is correct that only can be extracted the author and the link to the feeds but no the content of web sites that using software XenForo.

Thanks
 

TheRevTastic

Well-known member
#10
IPS said that they require content because it imports into a topic so importing no content wouldn't make a topic anywho, so mainly it's an issue for both platforms, or more like a compatibility issue.
 

Kevin

Well-known member
#11
... so mainly it's an issue for both platforms, or more like a compatibility issue.
See my response in the other thread; it is not an XF issue because the RSS specs only require an item title or description, not both. Sounds like IPS made assumptions not taking into account the actual RSS specs.
 

TheRevTastic

Well-known member
#12
See my response in the other thread; it is not an XF issue because the RSS specs only require an item title or description, not both. Sounds like IPS made assumptions not taking into account the actual RSS specs.
Well I think they see it as that you can't have an empty topic so they import content into it.
 

mrGTB

Well-known member
#14
IPS said that they require content because it imports into a topic so importing no content wouldn't make a topic anywho, so mainly it's an issue for both platforms, or more like a compatibility issue.
To be fair I kind of see your point on this one. I was going to import RSS Feeds from the XenForo Announcement forum board on my own site, mainly to keep updated with things via my own forum (new update release e.t.c). But when running the "Preview" of what gets displayed in a thread, I instantly decided it was a No go option.

True, it's very hard to import RSS Feeds onto a forum as THREADS if there's no topic content being pulled. There no point bringing in just a URL link alone and you can't class it as being a thread pulled in at all. I bet many others here have done the same, gone to pull XenForo RSS Feeds in and removed it after seeing what gets posted - nothing really!

RSS in XenForo is more designed for browser link feeds only, we're no content is required just a link-back.

But, if XenForo ever expand the RSS feature to include forum content. They must add a Global On|Off switch with it. There are too many sites now scrapping content on Blogs full of adverts to make money from your forums e.t.c. At least having only title pulled solves that problem right now and no global RSS Feed On|Off switch is needed