1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Richt-Text-Editor is blank on large Posts

Discussion in 'XenForo Questions and Support' started by wedge1001, Jul 7, 2014.

  1. wedge1001

    wedge1001 Member

    Hello,
    i'm having a problem with larger posts.
    Whenever i try to edit a large post, the editor will stay blank. A switch to the BB-Code editor won't work.
    the only way it's working is if i have disabled the richt-text editor on my settings.
    For me, the bb-code editor is enough, bot nor for my members.

    I've already googled, used the search, tried different proposals here.
    none of them have worked.

    on my machine i don't get any errors in my logs.
    neither nginx nore php

    i'm using nginx and php-fpm on a debian machine.

    Any idea and/or help?

    Thank you
     
  2. Mike

    Mike XenForo Developer Staff Member

    How large? How many characters and is there a lot of BB code?

    And you tagged this as 1.3, but can you confirm the specific version?
     
  3. wedge1001

    wedge1001 Member

    Hi,
    sorry for the late reply.

    at the moment we are running 1.3.1 (i haven't had time to update it yet)

    The Post has a huge amount of BB-Codes
    it has 850 Lines and each line has at least one opening and closing bb-code.
    It has a total of 52099 Characters (including bb-codes and blank lines)
     
  4. wedge1001

    wedge1001 Member

    so.
    i've updated to the 1.3.3 the newest version i've found in the members area.
    still the "error" is the same.
     
  5. Mike

    Mike XenForo Developer Staff Member

    That is a fairly long post. There may be limited amounts I can do as it stands as this is often down to some server limits (stack size, I believe) I have already changed this code several times to attempt to optimize it.

    Can you attach the raw BB code version of the post here?
     
  6. wedge1001

    wedge1001 Member

    Of course.

    i've set my stack-limit from 8MB to 32MB. Still no luck.

    <Attachment removed due to content -Mike>
     
    Last edited by a moderator: Jul 11, 2014
  7. Mike

    Mike XenForo Developer Staff Member

    I removed the attachment because of the content in it.

    Few questions:
    - OS?
    - PHP version? (admin.php?tools/phpinfo)
    - Value for the pcre.backtrack_limit setting in PHP (see phpinfo)
    - Value for the pcre.recursion_limit setting

    It's likely the backtrack or recursion limit, though I handled this post with 29000 and 11000, respectively; these values are significantly decreased from the default (1000000 / 100000).
     
  8. wedge1001

    wedge1001 Member

    no problem. Though s.th. like this.
    Debian 7.5
    Kernel-Version 3.2.0-4-amd64
    -> Linux <myname> 3.2.0-4-amd64 #1 SMP Debian 3.2.57-3+deb7u1 x86_64

    Version 5.5.12-1~dotdeb.1
    working as php-fpm
    -local limit: 10000000
    -master value: 10000000

    -local limit: 10000
    -master value: 10000

    Thanks for your help
     
  9. Mike

    Mike XenForo Developer Staff Member

    Right, it's very likely the pcre.recursion_limit setting. Apparently the PHP default here is actually 100000. I would recommend increasing that to at least something like 20000.
     
    wedge1001 likes this.
  10. wedge1001

    wedge1001 Member

    Hell yes!
    if set my recursion-limit to 30k and it works!
    thank you for your help!
     

Share This Page