1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Rich Text Editor

Discussion in 'Troubleshooting and Problems' started by Ablac, Sep 27, 2011.

  1. Ablac

    Ablac Active Member

    For some reason the Rich Text Edit dosn't work for me on my website but it works fine on Xenforo.

    I have checked my settings in my account and it says to use the Rich Text Editor.

    Ive tested this issue in Google Chrome, Firefox, Opera, and IE and get the same results in all 4.
    I have tested Creating a new topic, and replying to old ones by clicking more options.

    This is a strange issue and it seems as though im the only one experiencing this issue. Using xenforo.com i have the Rich Text editor so i don't understand why its only missing on my website :?
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  3. Ablac

    Ablac Active Member

    Na i checked it, and On xenforo.com when i click the A at the right of the Rich Editor I get an option below the Text Box to use the rich editor again on my site its not there :(

    Wonder if this is an issue with my site or if its a bug in 1.04 but its strange its only me :?
    Double Checking permissions its set to use the Rich Text Editor.
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That link doesn't show if you have the rich editor disabled in your user prefs.

    On your forum the preference page would be at this URL:

    http://theocraft.org/account/preferences

    There is nothing else to check.

    I just registered on your forum and confirmed that the rich editor is working.
     
    HydraulicJack likes this.
  5. Ablac

    Ablac Active Member

    Ya thats the interesting thing :?
    [​IMG]
     
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Do you have javascript disabled in your browser? Try a different browser or different computer.
     
  7. Ablac

    Ablac Active Member

    Thats the funny thing, it works fine on other computers, and it works fine on other sites with Xenforo, just dosnt work on mine :( and only for me :? which is strange cause its set to use the Rich Text Editor. If i go on another computer and login using my Account information i can see and use the Rich Text Editor :?
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

    All the evidence points towards a browser/cache problem.

    Clear all cache and cookies and try again.
     
  9. Ablac

    Ablac Active Member

    Still didn't work :? Not sure, must be an issue with my computer :? I used to have the same issue on Xenforo.com but when they updated to 1.1 it fixed it, so maybe when its released it will fix it on my site.
     
  10. EQnoble

    EQnoble Well-Known Member

    That's not how it works.

    If it is working for everyone else right now it IS your computer or software on it that has some kind of issue whether small or big, that is yet to be known. You should not rely on a remote computer to upgrade software to fix your problem.

    Try reinstalling your browser with the most updated version and no addons or customizations. If it works...one by one add your addons/changes back if any. If it breaks again you know your problem.

    It is not a problem with your site at all.
     
  11. Digital Doctor

    Digital Doctor Well-Known Member

    Uncheck the [ ] Use Rich Text editor (then save).
    Then check the [ ] Use Rich Text editor (then save).
     
  12. Ablac

    Ablac Active Member

    @EQnoble I haven't tried that yet, i will try that a soon as I get back on my computer

    @Digital Doctor I have tried that a few times thinking it might have just not updated the setting changes, but it didn't work :(
     
  13. Ablac

    Ablac Active Member

    I tried Uninstalling All my Browsers, Removing all Adons, Including Flashplayer, Silverlight, ECT anything that links to my Browsers, I even uninstalled Internet Explorer.

    I Installed Opera and Went to my website and it still dosnt work :? I will say though in my Settings if i have Rich Text Editor On when i edit a post i get
    Code:
    <p><span style="font-size: xx-large"><span style="font-weight: bold"><span style="color: #0000ff">Theocraft </span></span></p>
    That same Post with Rich Editor off in my Preferences i get
    Code:
    [SIZE=7][B][COLOR=#0000ff]Theocraft [/COLOR][/B][/SIZE] 
    Not sure if that means anything
     
  14. Ablac

    Ablac Active Member

    Ok i know im Triple Posting now but this is definatly an issue with my website :?

    I changed Operating Systems from Windows to Ubuntu and i still have the issue :?
    Not sure what would be causing me not to be able to access the Rich Text Editor.

    Is there some Permission Setting within the Admin CP that i might have set on accident :?
     
  15. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I already tested the editor on your forum using a test account. I can test it using your account if you are comfortable giving me your login.
     
  16. Ablac

    Ablac Active Member

    OK this is gana be sound weird but its something to do with my IP address... If I login on my phone using Verizons 4G the Rich Text Editor comes up, Same if i login using the internet at my school. Only when im at my house it dosn't work.

    If i take my laptop to school it works fine so its not the computer :? its something to do with my Router, Modem, or IP address. What could be stopping the Rich Texture Editor in those??

    I have a Motorola SurfBoard Modem, and an Apple Air Extreme Router.
     
  17. Digital Doctor

    Digital Doctor Well-Known Member

    Weird.
    Certainly unplug the router and plug it back in.
    If that doesnt work do it for the modem as well.

    Another way to "rule out" router problems is to plug the Cable modem directly into the PC (no router).
     
  18. Brogan

    Brogan XenForo Moderator Staff Member

  19. Ablac

    Ablac Active Member

    I have Time Warner Cable, and its their Docsis 3

    Tomorrow i can test my Website on another location using the Same ISP

    But whats strange is i can see the rich text Editor on Xenforo.com but not on my site :?
     
  20. Digital Doctor

    Digital Doctor Well-Known Member

Share This Page