1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

As Designed Rich Editor & Simple Editor Content Issue

Discussion in 'Resolved Bug Reports' started by yavuz, Nov 12, 2010.

  1. yavuz

    yavuz Well-Known Member


    I have recenly changed my forum to XenForo from vBulletin and have this little problem.

    When I use the center BB Code wrap the thread content with it, to center all the thread content, it adds hundreds of center BB Codes to every line when I change back to the simple editor. Maybe the screenshots would better explain

    This is my original code. Just used one Center TAG:


    This is when I swich to the rich editor and switch back to the simple editor:


    Hope this is not what is supposed to be because it adds hundrets of junk code which messes the thread content up.
    CyberAP and g0rn like this.
  2. Brogan

    Brogan XenForo Moderator Staff Member

    This is a known issue and has been discussed on several threads.
    I'm not sure if it has been posted in bug reports before, I'll see if I can find an earlier thread.

    I suspect though that it is due to line breaks, which results in the BB Code being applied to each separate line.
    laztrix likes this.
  3. yavuz

    yavuz Well-Known Member

    I wasn't aware Brogan. I've looked under bugs but couldn't find one.
    Thank You.
  4. Mike

    Mike XenForo Developer Staff Member

    That's not strictly a bug - the exact code used by the WYSIWYG editor will not necessarily match hand-written code, though the goal is to be visually the same.

    If you look at the HTML that a lot of browsers generate in rich text editors, you will see it reflects a centering of each line (paragraph).
    laztrix likes this.
  5. yavuz

    yavuz Well-Known Member

    I didn't have this issue with vb's editor when I swiched the editors. Because of that I thought this was some kind of a bug. But this is really "bugging" me and my members a lot. It would be much easier If only the code would remain as it was...
  6. Brogan

    Brogan XenForo Moderator Staff Member

    As far as I know, vB doesn't use a WYSIWYG editor.

    It is a plain text editor with BB Code buttons.
  7. g0rn

    g0rn Well-Known Member

    It does, however it doesn't work with Chrome and Safari iirc.
    CyberAP and laztrix like this.
  8. yavuz

    yavuz Well-Known Member

    That's true. It works with IE and firefox and with the latest version of Chrome but didn't until recently. I hope this can be fixed but seems the the developers are ok with the way it it is now.
  9. Luke F

    Luke F Well-Known Member

    It uses contentEditable, which has limited browser support. Personally I would like XenForo to use it too.
    laztrix likes this.

Share This Page