1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

As Designed Revert template doesnt' revert to original template

Discussion in 'Resolved Bug Reports' started by Itworx4me, Dec 28, 2010.

  1. Itworx4me

    Itworx4me Well-Known Member

    1. Beta 5
    2. Created a new style.
    3. Add something to the .css template
    4. Revert template

      Template reverts the status but not the template itself. It keeps the code that you added even if you revert the template.
    Thanks,
    Itworx4me
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Itworx4me. ;)

    I just tested this and I didn't have the problem you described.

    Have you been working in debug mode at all? Perhaps you edited the template in the Master Style which cannot be reverted. But you can run the upgrade in place to rebuild the master data which will effectively revert the Master Style.

    http://www.yoursite.com/forum/install/index.php?upgrade/
     
  3. Itworx4me

    Itworx4me Well-Known Member

    Let me give a more detailed instructions:

    1. Beta 5
    2. Appearance
    3. Style
    4. Create New Style Test
    5. Goto Test Templates
    6. Goto xenforo.css
    7. Add the following to body

      Code:
      body
      {
          @property "body";
          background-color: #222222;
          background-image: url(http://anim.tv/public/style_images/bubblesteel/bg.png);
          background-repeat: no-repeat;
          background-attachment: fixed;
          background-position: center center;
          font-family: 'Trebuchet MS', Helvetica, Arial, sans-serif;
          color: @contentText;
          word-wrap: break-word;
          line-height: 1.27;
          @property "/body";
      }
    8. Save and Exit
    9. Template now has a Red X to show customizations
    10. Click Red X to Revert Customizations
    11. Please confirm that you want to revert the customizations made in the style test to the following template: xenforo.css (Yes)
    12. Revist the xenforo.css template and the code that was added is still there. Even after you have reverted the Template

      Hope this helps
     
  4. Itworx4me

    Itworx4me Well-Known Member

    Did a bit more testing and it only seems to happen on the .css file names. If you goto style properties / general / body / and check the reset button. Update Style Properties. This seems to remove the added code but not reverting the template.

    Thanks,
    Itworx4me
     
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Confirmed. The custom CSS values are preserved after reverting the template. I had to go into the Style Properties to revert the Body.
     
  6. Mike

    Mike XenForo Developer Staff Member

    This is the designed behavior. When you edit between the @property tags, you're not actually editing the template - you're editing the style property.
     

Share This Page