• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Reset custom user permissions

Joeychgo

Well-known member
#1
I had a member I needed to give a temporary permission change to.

He no longer needs it - but - although I have changed the permission back, he still shows in the custom user permissions tab.

How do I make it so he's got his normal usergroup permissions?
 

Kevin

Well-known member
#5
@Joeychgo, did you find a solution?

I've migrated to XF2 and now a former staff member still shows up in the "User Permissions" listing but everything on the account is either set for "No" or a qty of "0". Not sure what/where the account is flagged as being different from a normal user.
 

Joeychgo

Well-known member
#6
@Joeychgo, did you find a solution?

I've migrated to XF2 and now a former staff member still shows up in the "User Permissions" listing but everything on the account is either set for "No" or a qty of "0". Not sure what/where the account is flagged as being different from a normal user.

Nope, I didn't.
 

Chris D

XenForo developer
Staff member
#7
In XF2 you can run the "Clean up permissions" tool which should handle some situations related to orphaned permissions values (where an add-on hasn't removed permission values on uninstall).

If it sticks behind after that, then it's likely a permission from a disabled add-on, so it may not be resolvable until the add-on is upgraded and then uninstalled.
 

Kevin

Well-known member
#8
In XF2 you can run the "Clean up permissions" tool which should handle some situations related to orphaned permissions values (where an add-on hasn't removed permission values on uninstall).

If it sticks behind after that, then it's likely a permission from a disabled add-on, so it may not be resolvable until the add-on is upgraded and then uninstalled.
Chris, I may be caffeine deficient at the moment... where's the Clean Up Permissions option in the ACP? I see there's a phrase for it but can't find it on a menu.:unsure: