1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Duplicate Reply to personal conversation doesn't update "was last seen"

Discussion in 'Resolved Bug Reports' started by imthebest, Aug 14, 2014.

  1. imthebest

    imthebest Formerly Super120

    Here is the scenario:

    Mike sends a PC to Kier. Then Kier starts reading the PC at 22:00, if Mike at 22:05 checks Kier's membercard it will say: "Kier was last seen: engaged in a conversation, 5 minutes ago". If Kier replies to the conversation at 22:10 and then Mike checks Kier's membercard again at 22:15 it will still say "Kier was last seen: engaged in a conversation, 15 minutes ago" when it should say "Kier was last seen: engaged in a conversation, 5 minutes ago" because the last action from Kier was the reply to the conversation, 5 minutes ago.
     
    semprot likes this.
  2. Amaury

    Amaury Well-Known Member

    Last edited: Aug 14, 2014
    semprot and imthebest like this.
  3. imthebest

    imthebest Formerly Super120

    I consider it as a bug. There has to be consistency.
     
  4. Martok

    Martok Well-Known Member

    I'd say that Mike & Kier need to hide their online activity as they are being stalked. ;)
     
    Liam W likes this.
  5. Liam W

    Liam W Well-Known Member

    Mike already has, not sure about Kier ;)
     
  6. Chris D

    Chris D XenForo Developer Staff Member

    This isn't exclusive to conversations. The same thing happens in threads when a message is posted and on profiles when messages are posted.

    AJAX actions do not update the session activity record.
     
    Daniel Hood likes this.
  7. Daniel Hood

    Daniel Hood Well-Known Member

    While in some situations I think it should update the last activity (since you know, submitting a form is generally a pretty big activity on a forum) this is definetely an "as designed" thing.
     

Share This Page