1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Reply ban overlay issue when there are many banned users

Discussion in 'Resolved Bug Reports' started by rellect, Aug 27, 2014.

  1. rellect

    rellect Well-Known Member

    I did few tests on the Reply Ban option, there are two issue that I found:

    1. There isn't pagination or some other way to limit results. I added more than 20 users and it shows them all. This is possibly an edge case as in normal conditions there shouldn't be so much banned users, but it may happen in long-time discussions.

    2. At some point the Reply Ban overlay's became partially hidden, And I couldn't scroll within it.

    reply ban.png
    Last edited: Aug 27, 2014
    Lexy likes this.
  2. Harpers Tate

    Harpers Tate Well-Known Member

    I believe the same behaviour occurs in all overlays, wherever it is taller than the screen or resolution of the display. Because it will not scroll, either internally or with the page contents underneath, it's wholly impossible to view the entire contents at all. (Except by reducing the font size - but thay only works within limits of course.)

    The overlay "thing" needs either an internal scroll, or to anchor to the page contents underneath.
  3. rellect

    rellect Well-Known Member

    Yea, the overlay probably needs to have max-height based on the viewport.
    I would even suggest to separate the banned list from the form. Show the ban list in a separate overlay/page (and if the list is long, provide some pagination).
  4. Chris D

    Chris D XenForo Developer Staff Member

    There are two built in methods of allowing "taller" overlays or more content within overlays.

    An overlay styled with "overlayScroll" gives the form within the overlay a maximum height with vertical scroll overflow. An overlay styled with the "NoFixedOverlay" class allows the entire overlay to have absolute position rather than fixed; and where the overlay is taller than the page, the page scrolls.

    @Harpers Tate if the issue is so prevalent, especially exasperated by a board as big as AVForums, it might be worth reporting them each specifically as a bug in case it's something that can be tweaked.
  5. Harpers Tate

    Harpers Tate Well-Known Member

    I wouldn't call it prevalent, as it (of course) depends on the content of the overlay. The one time I encountered it was on the Spam Cleaner, and when I was using a lower-res (768h) screen and I couldn't reach the buttons at the bottom. Leads me to believe that the behaviour is common/throughout. And will apply wherever window height isn't sufficient.
    In my case it was resolved by SW rearranging the overlay contents. If alternate styling methods work, then perhaps that needs to be better communicated?
  6. Chris D

    Chris D XenForo Developer Staff Member

    If current styling methods aren't working, perhaps that needs to be better communicated. I've not experienced, nor have I seen anyone else mention the Spam Cleaner dialogue being too big, before. That could mean it is specific to your style which does employ a number of larger fonts in and padding in some places. And as Stuart Wright was able to fix it, that may well be the case. If you ever see anything that's concerning, it may be worth testing it on the XenForo default style (I think as you're an Admin there you can switch to that) and if it's reproducible there then it's definitely worth reporting as a bug.
  7. Harpers Tate

    Harpers Tate Well-Known Member

    Noted, and yes, I can use the XF stylesheet. Thx.
  8. Mike

    Mike XenForo Developer Staff Member

    The issue here actually comes up as soon as someone is banned -- the overlay goes above our "acceptable" height, though it should work in most desktop cases (mobiles don't get fixed overlays as is).

    Regardless, as the height is unknown, overlayScroll needs to be applied. So fixed now, thanks!
    Lexy, Weydigo and Chris D like this.

Share This Page