1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Reoccurring Error

Discussion in 'Troubleshooting and Problems' started by Pixel Squad Ltd, Sep 1, 2016.

  1. Pixel Squad Ltd

    Pixel Squad Ltd New Member

    Over the past few weeks I keep getting the same two errors in my server error log and I don't know what they are.

    It's not the same user that is receiving and I don't know how severe the error is. So, just to make sure I thought I would post it here and see how I can prevent this error from happening.

    I sent out a mass email a few weeks back and my battery died on my phone before the operation completed and when I come back I had load of errors then. I don't know if that has anything to do with it.

    XF error.png

    Regards,
    Carl
     
  2. Mike

    Mike XenForo Developer Staff Member

    There's unlikely to be much you can do to prevent this, but can you show the stack trace from those messages?
     
  3. Pixel Squad Ltd

    Pixel Squad Ltd New Member

    @Mike yeah sure, here it is...

    Error Info

    Zend_Mail_Protocol_Exception: Email to (EMAIL ADDRESS) failed (after retry): 4.7.0 Try again later, closing connection. (MAIL) r127sm27697995wmf.23 - gsmtp -library/Zend/Mail/Protocol/Abstract.php:431
    Generated By: Unknown Account, Yesterday at 9:13 AM
    Stack Trace
    #0 /home/crimecoa/public_html/library/Zend/Mail/Protocol/Smtp.php(261): Zend_Mail_Protocol_Abstract->_expect(250, 300)
    #1 /home/crimecoa/public_html/library/Zend/Mail/Transport/Smtp.php(224): Zend_Mail_Protocol_Smtp->mail('mailer@crimecoa...')
    #2 /home/crimecoa/public_html/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Smtp->_sendMail()
    #3 /home/crimecoa/public_html/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
    #4 /home/crimecoa/public_html/library/XenForo/Model/MailQueue.php(91): Zend_Mail->send(Object(Zend_Mail_Transport_Smtp))
    #5 /home/crimecoa/public_html/library/XenForo/Deferred/MailQueue.php(10): XenForo_Model_MailQueue->runMailQueue(7.9999969005585)
    #6 /home/crimecoa/public_html/library/XenForo/Model/Deferred.php(295): XenForo_Deferred_MailQueue->execute(Array, Array, 7.9999969005585, '')
    #7 /home/crimecoa/public_html/library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 7.9999969005585, '', false)
    #8 /home/crimecoa/public_html/library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
    #9 /home/crimecoa/public_html/deferred.php(23): XenForo_Model_Deferred->run(false)
    #10 {main}
    Request State
    array(3) {
    ["url"] => string(44) "http://www.crimecoastforums.com/deferred.php"
    ["_GET"] => array(0) {
    }
    ["_POST"] => array(3) {
    ["_xfRequestUri"] => string(47) "/threads/switch-dual-account-in-one-device.346/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
    }
    }

    AND

    Error Info
    ErrorException: fwrite(): SSL operation failed with code 1. OpenSSL Error messages: error:140D00CF:SSL routines:SSL_write:protocol is shutdown -library/Zend/Mail/Protocol/Abstract.php:324
    Generated By: Unknown Account, Yesterday at 9:13 AM
    Stack Trace
    #0 [internal function]: XenForo_Application::handlePhpError(2, 'fwrite(): SSL o...', '/home/crimecoa/...', 324, Array)
    #1 /home/crimecoa/public_html/library/Zend/Mail/Protocol/Abstract.php(324): fwrite(Resource id #72, 'QUIT\r\n')
    #2 /home/crimecoa/public_html/library/Zend/Mail/Protocol/Smtp.php(385): Zend_Mail_Protocol_Abstract->_send('QUIT')
    #3 /home/crimecoa/public_html/library/Zend/Mail/Transport/Smtp.php(183): Zend_Mail_Protocol_Smtp->quit()
    #4 /home/crimecoa/public_html/library/XenForo/Model/MailQueue.php(87): Zend_Mail_Transport_Smtp->resetConnection()
    #5 /home/crimecoa/public_html/library/XenForo/Deferred/MailQueue.php(10): XenForo_Model_MailQueue->runMailQueue(7.9999969005585)
    #6 /home/crimecoa/public_html/library/XenForo/Model/Deferred.php(295): XenForo_Deferred_MailQueue->execute(Array, Array, 7.9999969005585, '')
    #7 /home/crimecoa/public_html/library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 7.9999969005585, '', false)
    #8 /home/crimecoa/public_html/library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
    #9 /home/crimecoa/public_html/deferred.php(23): XenForo_Model_Deferred->run(false)
    #10 {main}
    Request State
    array(3) {
    ["url"] => string(44) "http://www.crimecoastforums.com/deferred.php"
    ["_GET"] => array(0) {
    }
    ["_POST"] => array(3) {
    ["_xfRequestUri"] => string(47) "/threads/switch-dual-account-in-one-device.346/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
    }
    }
     
  4. Mike

    Mike XenForo Developer Staff Member

    The second error is happening because of the first. I'll see if I can prevent that in future.

    However, ultimately, it's the first one that's causing the problem, and this is Gmail's SMTP server rejecting you for some reason. They aren't giving a specific reason, though it might be rate limiting. If you're sending a lot of mail, it may be time to use a different SMTP provider.
     

Share This Page