1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Remove Profile Posts 1.0.1

Removes Profile Posts related stuff that isn't removed by setting all Profile Posts Permission to No

  1. ge66

    ge66 Active Member

    ge66 submitted a new resource:

    Remove Profile Posts - Removes Profile Posts related stuff that isn't removed by setting all Profile Posts Permission to No

    Read more about this resource...
     
    Mirovinger and sbj like this.
  2. RyanC

    RyanC Active Member

    Seems to be working for me... This was really needed....
     
  3. ge66

    ge66 Active Member

    Thank you!
     
    51463 likes this.
  4. sbj

    sbj Well-Known Member

    This is a bit buggy though.
     
  5. ge66

    ge66 Active Member

    I have not checked it against the latest versions of xenforo yet, if things have changed there some things could have stopped working.
     
  6. Axel B

    Axel B Well-Known Member

    Hi m8,
    Found your addon doing a lot of the removal of Profile Posts. Just what I was looking for :) Just installed it and have not found any errors in the log. Good work!

    I have one small request. Can you also have your addon remove the tab New Profile Posts under New Posts?
    Screenshot 2015-03-07 18.48.04.png
     
  7. Axel B

    Axel B Well-Known Member

    Hi ge66,
    Found another little leftover from Profile Posts under Members. The link to New Profile Posts is still there. Can you remove that one too?
    Screenshot 2015-03-07 21.02.42.png

    Thanks for your time!
     
  8. robart

    robart Member

    Thanks for this
     
  9. ge66

    ge66 Active Member

    I have checked this against XF 1.4.5 and it should still work.
     
  10. ge66

    ge66 Active Member

    If you have made changes to the templates that this works with it could result in problems.
     
  11. ge66

    ge66 Active Member

    I think your problems is related to you not "setting all Profile Posts Permission to No" as I mention in the resource description.
     
  12. ge66

    ge66 Active Member

    Thank you, and if anybody would like to rate this, please do :)
     
    robart likes this.
  13. sbj

    sbj Well-Known Member

    As far as I know none of my add-ons change something in profile page but it could be.

    The bug occurs when you on someone's profile page and click the tabs in profile page. When you click on all of them and you keep clicking randomly, after some little time the last tab shows different information than it should show.
     
  14. Axel B

    Axel B Well-Known Member

    You are absolutely right. Adjusted the authorizations and everything is gone :) THANKS!
     
  15. Phillip

    Phillip Active Member

    We are getting ready to upgrade from XenForo 1.3.5 to 1.4.7. We are currently running the "Remove Profile Page Tabs" add-on from @AndyB. If I'm understanding everything correctly, we need to uninstall Andy's add-on and then install this one in order to fully disable and remove all profile posts. Is that correct?

    Any other wisdom from those who've already done this would be most appreciated.
     
    Last edited: Jun 20, 2015
  16. ge66

    ge66 Active Member

    I honestly don't know.
    I always think it is a good idea to have a (local) test installation when doing changes, more important the bigger the changes are, to test there first to see if everything works out as I thought. After that you can do the changes to the real site.
     
  17. Phillip

    Phillip Active Member

    We just upgraded from 1.3.5 to 1.4.7 yesterday. All of our profile post permissions have been set to "no" for several years. After the 1.4.7 upgrade we installed this plugin to easily remove those references from the forum.

    Here is the issue. The "new profile posts" sidebar is not visible on our forum when logged in, however, it is visible for guests. The "new profile posts" tab and other areas are also visible. Is this intentional behavior with this add-on?
     
  18. ge66

    ge66 Active Member

    On my site it is working even when logged out, just tested.
    I am not using "Remove Profile Page Tabs" so that may be the reason for it not working or something else might have changed something in the templates that this add-on looks for.
    I think I might have had to reinstall it one time when it didn't seem to work.
     
  19. Phillip

    Phillip Active Member

    AndyB's plugin was uninstalled before we upgraded to 1.4.7. Please confirm what templates I should check for your plugin and we'll look into it further. The system is showing no outdated templates, no outdated phrases and a positive health check after the upgrade.

    I'll give that a try to see if the plugin will take the second time for guests, thanks.
     
  20. Phillip

    Phillip Active Member

    This has been fixed. Our "unregistered" profile post permissions were set to "view profile posts" for guests even though this was turned off everywhere else.

    Thanks @ge66 for the help!
     

Share This Page