• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Remove Profile Posts 1.0.1

No permission to download

ge66

Active member
#1
ge66 submitted a new resource:

Remove Profile Posts - Removes Profile Posts related stuff that isn't removed by setting all Profile Posts Permission to No

This addon is inspired by Remove Profile Page Tabs by AndyB, but this one only removes things related to profile posts that isn't removed by setting all Profile Posts Permission to No.

It only works for XF 1.4

Removes profile posts related stuff from the following templates:
account_alert_preferences
account_privacy
member_view
search_bar
search_form_tabs

This i my first. I’m no developer. So if anyone would like to take over this or come with ideas of how it can be done better, please do.
Read more about this resource...
 

ge66

Active member
#5
I have not checked it against the latest versions of xenforo yet, if things have changed there some things could have stopped working.
 

Axel B

Well-known member
#6
Hi m8,
Found your addon doing a lot of the removal of Profile Posts. Just what I was looking for :) Just installed it and have not found any errors in the log. Good work!

I have one small request. Can you also have your addon remove the tab New Profile Posts under New Posts?
Screenshot 2015-03-07 18.48.04.png
 

Axel B

Well-known member
#7
Hi ge66,
Found another little leftover from Profile Posts under Members. The link to New Profile Posts is still there. Can you remove that one too?
Screenshot 2015-03-07 21.02.42.png

Thanks for your time!
 

sbj

Well-known member
#13
If you have made changes to the templates that this works with it could result in problems.
As far as I know none of my add-ons change something in profile page but it could be.

The bug occurs when you on someone's profile page and click the tabs in profile page. When you click on all of them and you keep clicking randomly, after some little time the last tab shows different information than it should show.
 

Phillip

Active member
#15
We are getting ready to upgrade from XenForo 1.3.5 to 1.4.7. We are currently running the "Remove Profile Page Tabs" add-on from @AndyB. If I'm understanding everything correctly, we need to uninstall Andy's add-on and then install this one in order to fully disable and remove all profile posts. Is that correct?

Any other wisdom from those who've already done this would be most appreciated.
 
Last edited:

ge66

Active member
#16
I honestly don't know.
I always think it is a good idea to have a (local) test installation when doing changes, more important the bigger the changes are, to test there first to see if everything works out as I thought. After that you can do the changes to the real site.
 

Phillip

Active member
#17
We just upgraded from 1.3.5 to 1.4.7 yesterday. All of our profile post permissions have been set to "no" for several years. After the 1.4.7 upgrade we installed this plugin to easily remove those references from the forum.

Here is the issue. The "new profile posts" sidebar is not visible on our forum when logged in, however, it is visible for guests. The "new profile posts" tab and other areas are also visible. Is this intentional behavior with this add-on?
 

ge66

Active member
#18
On my site it is working even when logged out, just tested.
I am not using "Remove Profile Page Tabs" so that may be the reason for it not working or something else might have changed something in the templates that this add-on looks for.
I think I might have had to reinstall it one time when it didn't seem to work.
 

Phillip

Active member
#19
I am not using "Remove Profile Page Tabs" so that may be the reason for it not working or something else might have changed something in the templates that this add-on looks for.
AndyB's plugin was uninstalled before we upgraded to 1.4.7. Please confirm what templates I should check for your plugin and we'll look into it further. The system is showing no outdated templates, no outdated phrases and a positive health check after the upgrade.

I think I might have had to reinstall it one time when it didn't seem to work.
I'll give that a try to see if the plugin will take the second time for guests, thanks.
 

Phillip

Active member
#20
This has been fixed. Our "unregistered" profile post permissions were set to "view profile posts" for guests even though this was turned off everywhere else.

Thanks @ge66 for the help!