• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Registration Email

#1
I just started my site and I'm not getting my email to active my test account. This is the error log i get!

Zend_Mail_Transport_Exception: Unable to send mail. - library/Zend/Mail/Transport/Sendmail.php:137
Generated By: RoastKing, 11 minutes ago
Stack Trace
#0 /hsphere/local/home/.net/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Sendmail->_sendMail()
#1 /hsphere/local/home/.net/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#2 /hsphere/local/home/.net/library/XenForo/Mail.php(177): Zend_Mail->send()
#3 /hsphere/local/home/.net/library/XenForo/Mail.php(152): XenForo_Mail->sendMail(Object(Zend_Mail))
#4 /hsphere/local/home/.net/library/XenForo/Model/UserConfirmation.php(124): XenForo_Mail->send('datraggernaut@g...', 'RoastKing')
#5 /hsphere/local/home/.net/library/XenForo/ControllerPublic/AccountConfirmation.php(98): XenForo_Model_UserConfirmation->sendEmailConfirmation(Array)
#6 /hsphere/local/home/.net/library/XenForo/FrontController.php(310): XenForo_ControllerPublic_AccountConfirmation->actionResend()
#7 /hsphere/local/home/.net/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#8 /hsphere/local/home/.net/index.php(13): XenForo_FrontController->run()
#9 {main}
Request State
array(3) {
["url"] => string(50) "http://.net/account-confirmation/resend"
["_GET"] => array(0) {
}
["_POST"] => array(5) {
["_xfToken"] => string(53) "2,1348623517,159fc8fad488b90cf8903674d9654e8ec4b6ac6c"
["_xfConfirm"] => string(1) "1"
["_xfRequestUri"] => string(17) "/members/dagod.1/"
["_xfNoRedirect"] => string(1) "1"
["_xfResponseType"] => string(4) "json"
}
}
 

Jake Bunce

XenForo moderator
Staff member
#11
I think I replied to your support ticket.

That error means the mail is failing. Which server are you using?

Admin CP -> Home -> Options -> Email Options -> Email Transport Method

The default server would be your web host, meaning you need to contact them about PHP's internal mail not working. Or you can specify a SMTP server. Here is a guide for using Google as your SMTP server:

http://xenforo.com/community/threads/setting-up-google-as-smtp-server-for-your-xenforo.6180/