1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Redirect Problem

Discussion in 'Troubleshooting and Problems' started by Inkman, Feb 28, 2014.

  1. Inkman

    Inkman Active Member

    Hi.
    I am having a problem when people type in wirraltalk.co.uk into IE its directing them to http://www.wirraltalk.co.uk/wirraltalk now i am not sure why its taking them to /wirraltalk because there is nothing there and then causing an error.

    I did contact my domain service where the control panel is but they have said it will be a problem for my host to look into but i have just contacted my host and they have said:
    The server side seems ok. You may want to contact the forum developer on why it redirects.

    Could anyone please advise me best how to stop this please?
     
  2. Mike

    Mike XenForo Developer Staff Member

    I don't get a redirect when I visit in IE.
     
  3. arms

    arms Active Member

    Your .htaccess is configured wrong.

    http://www.wirraltalk.co.uk/ works

    http://wirraltalk.co.uk/ takes you to http://www.wirraltalk.co.uk/wirraltalk
     
    Inkman likes this.
  4. Inkman

    Inkman Active Member

    Hi @Mike it was first reported by a member and then when i typed wirraltalk.co.uk without the www it sends me to the forward slash wirraltalk which causes an error, can you clarify if you tried it without the www please.
     
  5. Inkman

    Inkman Active Member

  6. Brogan

    Brogan XenForo Moderator Staff Member

    Update your .htaccess file.
     
  7. Inkman

    Inkman Active Member

    Ok i have just deleted the .htaccess and uploaded one from the version i am using and tried the page again and its still redirecting...
     
  8. Inkman

    Inkman Active Member

    Ok i have figured out what is causing this, its the addon called Vanity Name by @Liam W
    I have now disabled the addon and i am not having the problems any longer. Thanks to all who replied here and via PM
     
  9. Liam W

    Liam W Well-Known Member

    I shall look into it. I basically check to see if the domain is the same as the one specified in the options, and if it isn't the addon assumes that it's a vanity names sub-domain permalink.

    Liam
     
    Inkman likes this.

Share This Page