1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MG 1.1 Random/Recent Media Block Forum

Discussion in 'Media Gallery Support' started by Davyc, Jan 8, 2016.

  1. Davyc

    Davyc Well-Known Member

    I've activated the Random/Recent media block to show on the forum for XFMG, but nothing is showing other than a horizontal line that moves vertically (see screen shot)


    There are only embedded videos in the Gallery so could that be the problem or is there a setting I'm missing?

    I've tried this with both the custom style I'm using and the default style with no change.

    Thanks in advance for help.
  2. Chris D

    Chris D XenForo Developer Staff Member

    This came up very recently and it has escaped me as to what was the exact cause. Let me find that thread and I'll get back to you :)
  3. Chris D

    Chris D XenForo Developer Staff Member

    Actually, would you mind submitting a ticket from your customer area with a log in so I can access your site and see this myself?

    I can't find the thread, now, but if I can take a quick look I'm sure it will be straight forward.
  4. Davyc

    Davyc Well-Known Member

    OK I've tried a few things and one of the things that I failed to mention is that I have no sidebar on the forum list. Using Widget framework I cleared it as it is on the CTA featured threads page.

    When I removed the 'Clear Sidebar' widget and the sidebar returned the media was showing - weird! Is there any way to correct this using CSS or a template edit as I really don't want the sidebar on the forums list?
  5. Davyc

    Davyc Well-Known Member

    Sent ticket!
  6. Chris D

    Chris D XenForo Developer Staff Member

    Ah, I seem to have found the other thread I mentioned:


    This seems to suggest the same thing; it is only a problem when Widget Framework is enabled and the Clear sidebar widget is used.

    This apparently does something weird to the HTML which we can't support (specifically the .mainContent div goes missing). This is likely something that would need to be resolved by xfrocks, the widget framework developer (sometimes he has newer versions available on his site that aren't in our resource manager).
  7. Davyc

    Davyc Well-Known Member

    OK thanks for taking a look Chris it's much appreciated. I'll have a look over at Xfrocks and see if there's anything new.

  8. drastic

    drastic Well-Known Member

    Funny....same thing just recently began happening to me today.

    I disabled XFrocks BDCache because it caused my ads to NOT appear, but then my recent media vanished from my forum list.

    It looks like this now. Cleared every cache I know of, turned the block on/off/on, etc... nothing helped. no random media.jpg
  9. Chris D

    Chris D XenForo Developer Staff Member

    This is a totally different issue.

    According to the browser console (F12) you have various Javascript errors. It's possible one of these is having a knock on effect on other JS code running on the page (including the media block).

    Have you made any other changes today? Specifically anything to do with ads or any other add-ons?
  10. drastic

    drastic Well-Known Member

    I removed BD Cache because it prevented some of my ads from appearing.
  11. Chris D

    Chris D XenForo Developer Staff Member

    Are you not seeing the other issues with your forum home page?

    Such as when you click on the Style Chooser or a user's name? It should open content in an overlay, but that for some reason isn't working either. It's likely to do with these various JS errors that are happening.

    Are you easily able to disable your ads (temporarily)?
  12. drastic

    drastic Well-Known Member

    Didn't even notice that. I only have one style (besides the default), would like to disable selecting completely if I can.

    Can disable ads no problem. Will do so now.

    @Russ is there any js in our style that might cause any conflicts?
  13. drastic

    drastic Well-Known Member

    ads disabled, random media thumbs are back. It must've been an ad code conflicting somehow...I think.

    edit: yup. Our overlay exit pop causes other things to not work. When I enable that ad, things go away. When it's turned off, things work as normal.

    Now the question is how do we make them friendly and work together....

Share This Page