XF 2.2 Push notifications

MichaelR

Member
I installed 2.2 rc2 but i'm not seeing the popup "XenForo community would like your permission to enable push notifications" on my desktop. On mobile i can install the pwa and have no problems there. All is green so to speak. I do see the notification on this website so something is different.
I have been looking all over the admin panel what i'm doing wrong but i cant really find something. Any ideas what i can check?
 

Mike

XenForo developer
Staff member
Assuming you've enabled it in the control panel (and it does look like you have), go to your preferences page (/account/preferences). You should see an option there to control push notifications:

1601028769169.png

Note that push notifications are setup per device, so if you enable it on your desktop, it won't change this on your mobile, for example.
 

MichaelR

Member
Assuming you've enabled it in the control panel (and it does look like you have), go to your preferences page (/account/preferences). You should see an option there to control push notifications:

View attachment 235827

Note that push notifications are setup per device, so if you enable it on your desktop, it won't change this on your mobile, for example.
Thank you. I don't see this button in the pref page.. I doubled checked the settings just now. I have all enabled but somehow now I'm missing 2 options that are required. (gmp, openssl extensions) in my 7.4 PHP settings page. Ill contact my server provider. I'm pretty sure i checked this before and then all was OK.
 
Top