• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 Problem with xenforo and smtp

#1
Hello, I have some people that are hitting my site with a ddos atack, I am using cloudflare for hidden my server ip, but is useless because when you use like "forgot password" and you send one email into your inbox, it will show my server ip in the "original" like this:
Received: from localhost (unknown [192.184.**.**])

Im using namecheap mailserver and please I really need to know how to fix this, is really important I need to hidden my ip from emails
 

Mike

XenForo developer
Staff member
#2
It's your SMTP provider that is adding the source IP in. This is a pretty standard thing; I've never seen a provider that doesn't. You would need some way of passing the mail off to an SMTP server that doesn't add the extra data, though that may technically violate the spec. (It would likely need to be done through a server you control so you can configure the SMTP service as necessary.)
 
#3
It's your SMTP provider that is adding the source IP in. This is a pretty standard thing; I've never seen a provider that doesn't. You would need some way of passing the mail off to an SMTP server that doesn't add the extra data, though that may technically violate the spec. (It would likely need to be done through a server you control so you can configure the SMTP service as necessary.)

Maybe Can I create on my vps my own smtp server? I really have no idea of what I must do for stop that issue, And I really need cause my site is kinda important and im getting ddossed
 

Tracy Perry

Well-known member
#4
Maybe Can I create on my vps my own smtp server? I really have no idea of what I must do for stop that issue, And I really need cause my site is kinda important and im getting ddossed
Wouldn't using a provider like Mandrill solve this problem? Depending on how many emails you send a month it could be a possibility. With them you get the first 12,000 emails free, then there is a fee scale that comes into play.

The other option should be setting up a VPS like you outlined and installing postfix on it to relay your mail from your server. That should then show the IP of the VPS as the origin.
This is one that I'm looking at doing in the near future as I have a /24 CIDR and if my mail server starts getting hit I'll just null route it and assign a new IP to it with a few other changes.
 

Mike

XenForo developer
Staff member
#5
Wouldn't using a provider like Mandrill solve this problem?
It's very likely that there will be an indication in Mandrill that your server connected to send the message to them. So yeah, this is something where you'd probably need a separate server to be the one connecting to the external provider and stripping out the header (http://moblog.wiredwings.com/archives/20100501/remove-ips-from-outgoing-mail-postfix-smtp.html)... which technically violates the spec.
 
#6
It's very likely that there will be an indication in Mandrill that your server connected to send the message to them. So yeah, this is something where you'd probably need a separate server to be the one connecting to the external provider and stripping out the header (http://moblog.wiredwings.com/archives/20100501/remove-ips-from-outgoing-mail-postfix-smtp.html)... which technically violates the spec.
Wouldn't using a provider like Mandrill solve this problem? Depending on how many emails you send a month it could be a possibility. With them you get the first 12,000 emails free, then there is a fee scale that comes into play.
Hello guys, I used mandrill for a test but mandrill still shows the ip:
Received: from [192.184.93.**] by mandrillapp.com

Should I change any config on mandrill? and about to install my own postfix I tried but that is a really hard job for me so far I do not have big knowledge