1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with RSS Feed from here

Discussion in 'General XenForo Discussion and Feedback' started by TheRevTastic, Nov 30, 2011.

  1. TheRevTastic

    TheRevTastic Well-Known Member

    Well I imported an RSS feed from the announcements forum here onto bb-styles.com, but every time I try to update it to fetch the feed it skips over the topics in there and says it has no title or content.

    Is this an issue with IP.Board or the RSS feed here?
  2. Lycaon

    Lycaon Well-Known Member

    I would say it's with IPB. I just tried it with XF and it works fine.
  3. TheRevTastic

    TheRevTastic Well-Known Member

    Hmm, well try it with a local install, and if happens again will bring it up over on the IPS forums.

    Edit: Doesn't work on a local install either.
  4. optrex

    optrex Active Member

    Would it be to do with the fact there is just titles and no description of whats in a given topic?
  5. mrGTB

    mrGTB Well-Known Member

    There is no description offered in XenForo RSS feeds, only the topic title can be pulled. In your IPB RSS Feed code options, try removing stuff so only title is being pulled and see what it says then. I used to use IPB 3.0.6 RSS Feed and always found it worked fine pulled feeds from the BBC News site, but they offer both title and description.

    Bit pointless pulling XenForo feeds really because of that, you'll only get a title link displayed. Not exactly worth pulling in without a text description of some sort.
  6. TheRevTastic

    TheRevTastic Well-Known Member

    Don't think there's any settings like that http://www.diigo.com/item/image/1f5jc/unog :p

    Also the RSS feed from here doesn't validate http://validator.w3.org/feed/check.....com/community/forums/announcements/index.rss
  7. mrGTB

    mrGTB Well-Known Member

    I don't mean a setting as such, like a checkbox for example. I mean the bigger square box that list code used to pull feed aspects in. It's been a while I last used IPB so don't even remember if that is there to change.

  8. TheRevTastic

    TheRevTastic Well-Known Member

    Nope we don't have a setting like that.
  9. mrGTB

    mrGTB Well-Known Member

    You see that's the thing I never liked about IPB, features are always pretty basic and simple with next to no flexibility.
  10. Kevin

    Kevin Well-Known Member

    We do in XenForo! :D

    But, seriously, as mrGTB is saying, the problem is likely IPB not liking the RSS feed from here not having an item description (aka: content); it only has the item title. If you view the RSS feed from here in your browse (you might have to do a 'view source' to see the raw XML) you'll see what he means.
  11. TheRevTastic

    TheRevTastic Well-Known Member

    I use Chrome so I automatically see the raw XML, but I've ran validations on the RSS feeds from here, AdminExtra and now VoiceRadio.us and they all don't validate as every other RSS Feed (be it blogs, vbulletin forums, etc) get imported into my IPB forum.

    I submitted a bug report to see if they can fix the validation of the RSS Feed which will most likely work.
  12. mrGTB

    mrGTB Well-Known Member

    I guess it could be a validation thing with IPB. I do remember when using IPB 3.0.6 that it checked to see if it was a valid UTF-8 feed. The feed would still work (from what I remember), but it let you know if you was subscribing to a feed that wasn't proper validated to UTF-8. But to be fair, you'll find loads of well known popular feeds that don't validate. The BBC News seem to offer great feeds that are also well validated unlike many other sites out there.

    It might also be a case, because your IPB is trying to pull both content and title. That it won't accept a feed without both being offered. No idea, but that could be the case and only IPB themselves will be able to answer that one. You could try finding another site only offering title to be pulled and see if that works also, but not an XenForo site.
  13. TheRevTastic

    TheRevTastic Well-Known Member

    IIRC the IPB RSS feed offers the title to be pulled, don't remember for sure though.
  14. Luis

    Luis Well-Known Member

    @ TheRevTastic.

    The problem must be Xenforo Software.

    If I can extract the contents of other websites.

    But I can not extract content from any Web Xenforo software. I tried with 5 Xenforo sites.

    The only thing I draw is the title and author.

    I leave this comment if it's something.

  15. Kevin

    Kevin Well-Known Member

    The 'valid feed' issue not related to not having the description (content) in the item feed. The XF feed fails validation for having two author tags (http://validator.w3.org/feed/check.cgi?url=http://xenforo.com/community/forums/announcements/index.rss), not because there is no description. Per the RSS 2.0 specs (http://cyber.law.harvard.edu/rss/rss.html) an item only requires either the title or description, not both. In that regards even if the guys fixed it so that there is only one author tag and it passes the W3 validation it doesn't mean there will be a description present.

    Your best bet, really, is to verify with IPS why it is failing to be consumed by IPB. If it is failing because the invalid validation, the double authors, then yes, that is an issue with XF to fix but if it is failing because there is no description then that is an issue with IPB since the RSS specs don't require both elements to be present.
  16. mrGTB

    mrGTB Well-Known Member

    Something worth mentioning. I'm using TwitterFeed to pull my own threads via RSS into both Twitter and Facebook. I have no issues with Twitterfeed doing it at all as the image shows of Facebook.


Share This Page