1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with "Mark Viewed" link

Discussion in 'Media Gallery Support' started by imthebest, Jul 12, 2015.

  1. imthebest

    imthebest Formerly Super120

    On this forum when I'm on find-new/xxxxxx/media after I click on "Mark Viewed" and confirm the action, the page reloads and a message telling that "You have no unviewed media..." appears.

    However on my forum when I'm on news/xxxxxx/photos (yep, route filters) after I click on "Mark Viewed" and confirm the action, the page also reloads however it still display the same media. I need to click on another tab like "New profile posts" and then again on "New media" in order to see the "You have no unviewed media..." (because if I just reload the page it will load the same news/xxxxxx/photos which still shows the media).

    What could be going on? Maybe a bug with the behavior of the "Mark Viewed" when using router filters?

    Last edited: Jul 12, 2015
  2. imthebest

    imthebest Formerly Super120

    Please help :(
  3. Brogan

    Brogan XenForo Moderator Staff Member

    If you remove the route filters does it work as expected?
  4. Chris D

    Chris D XenForo Developer Staff Member

    Also, what are the exact route filters you're using, as it works fine for me.

    EDIT: Actually - you've changed media to photos too, let me test that...

    EDIT2: Yep, still works fine for me.
  5. imthebest

    imthebest Formerly Super120

    Just tested and when I disable this route filter:

    find-new/{num:digit}/media -> news/{num:digit}/photos
    It works just fine. So is this a bug or a bad route filter?
  6. Chris D

    Chris D XenForo Developer Staff Member

    You're actually missing a route filter which, although doesn't seem ever-so important, does affect this.

    You need to add a route filter for:

    find-new -> news

    That's why it worked for me.

    This is my list:

    imthebest likes this.
  7. imthebest

    imthebest Formerly Super120

    I see you are using {name:digit} instead of {num:digit}. What should I use?
  8. Chris D

    Chris D XenForo Developer Staff Member

    It doesn't appear to matter what prefix is used for the placeholders, there, but {name:digit} is the documented way.
    imthebest likes this.

Share This Page