1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Problem with CloudFlare Free SSL (solved)

Discussion in 'Troubleshooting and Problems' started by A.Chakery, Apr 1, 2015.

  1. A.Chakery

    A.Chakery Active Member


    I am having problem with cloud flare free SSL plan.

    Please take a look at below test :

    As you can see both NONE SSL and SSL objects are being loaded and unfortunately considering the I have set https version of my URL in as Board URL in XenForo options.

    Would you please help me to solve this issue ?

    Domain : livetalk.us

    Thank you
  2. Mike

    Mike XenForo Developer Staff Member

    I assume CloudFlare isn't requesting your server over HTTPS? That's the big issue and ideally should be resolved.

    If you can't, you can put this in config.php:
    $_SERVER['HTTPS'] = 'on';
  3. A.Chakery

    A.Chakery Active Member

    Thank you very much Mike. It solved my problem.

    Just for all those who want to use CloudFlare Free SSL service ..

    You should do three things to implant CF SSL :

    1- Change your board URL in XF Options to https://your-domain.com

    2- add below code to config.php of XF (as mike mentioned)
    $_SERVER['HTTPS'] = 'on';
    3- Add a Page Rule in CF to you URL (Note you should enter your url like this : your-domain.com/*

    I hope it helps....

    Thank you gain mike.
    allewreK and BassMan like this.
  4. BassMan

    BassMan Well-Known Member

    Great, just what I need it.

    @Mike , I'm using my forum on a subdomain forum.domain.com. When I go to main site https://forum.domain.com I have a yellow triangle in front, but all other pages like forum.domain.com/members have a green lock icon.

    What could it be?
  5. BassMan

    BassMan Well-Known Member

    Ok, I think I know what it causes. On forum list I have some links that points to a non https site. I guess I need to fix this somehow, right?
  6. BassMan

    BassMan Well-Known Member

  7. Brogan

    Brogan XenForo Moderator Staff Member

    Use the image and link proxy function.
  8. BassMan

    BassMan Well-Known Member

    Can you please point me to right direction here. Never done anything like that.
  9. Brogan

    Brogan XenForo Moderator Staff Member

    ACP search: proxy
  10. Zynektic

    Zynektic Well-Known Member

    ACP > Options > Messages

    You can find image/link proxy there.
  11. BassMan

    BassMan Well-Known Member


    I enable it, but it's still the same.
  12. BassMan

    BassMan Well-Known Member

    Btw, those links and images are from external sites.
  13. BassMan

    BassMan Well-Known Member

  14. Mike

    Mike XenForo Developer Staff Member

    I don't know if you've resolved the issue, but I don't see the error on your site.

    The proxy only changes content in messages. If you're getting the error from something other than a message, you need to change that to use HTTPS.
  15. BassMan

    BassMan Well-Known Member

    @Mike , I've removed images from my forum list. I'll pm you the page where you can see the issue. Still not sure how to solve this.
    Last edited: Jun 23, 2015
  16. rafass

    rafass Well-Known Member

    This code in my config.php have solved my issue, with Cloudflare.
    Many thanks!

Share This Page