1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 [Problem solved] Install (with WordPress) in a subdirectory?

Discussion in 'Installation, Upgrade, and Import Support' started by Zeilenschreiber, May 6, 2014.

  1. Hello everyone - i am new to this and as you can see, this is my very first post here. I already read this question from another User - but i didn't get it.

    The following shoes, what i'd like to attain referring to the path of the xenForo:
    mysite.com/community/

    WordPress is already installed in (server-path) /directory/wordpress
    Works nice so far. My idea was to make a new directory directly here: /directory/wordpress/community
    I uploaded all files into the directory "community" and started the install-process. Worked nice ... but when i logged out or try to click "forums" i get a 404 from WordPress. So my idea wasn't that good, was it?

    As you see by now - i need some help. Is it possible to get my wished-path somehow?
     
  2. Mike

    Mike XenForo Developer Staff Member

    Normally you can do what you want without issue, though I suppose it depends on the WordPress configuration in .htaccess. Did you upload XenForo's .htaccess file? Can you provide the URL where you installed XenForo?
     
  3. Sure - you'll find it here: http://goldschmiede-cafe.de/forum/
    As you see, there is no further content by now. My main goal is to bring all things (there is more stuff - a small portal and a small vB4 forum - currently under another domain) in one house ... meaning one domain.
    Alternative i could create a subdomain like "community.goldschmiede-cafe.de" ... but if i am honest, i don't like it.

    I uploaded all files including the .htaccess file, yes.
     
  4. Mike

    Mike XenForo Developer Staff Member

    That really looks like the .htaccess isn't working as expected (assuming you're running Apache of course). If you temporarily rename the .htaccess in the WordPress directory, do the friendly URL-based XenForo links work?

    If not, then it won't be related to WP. You may need to setup the RewriteBase path or ensure that AllowOverride is enabled (though if the WP .htaccess works, that particular thing shouldn't be an issue).
     
  5. I renamed it - now i get a hint from Apache, the index.php wasn't found on the server.
     
  6. kingofseo

    kingofseo New Member

    Can you add this to your .htaccess file please ?

    Code:
    RewriteBase /forum
     
    Zeilenschreiber likes this.
  7. Done ... and it works! That's great, thank you!

    Explanation - i tried RewriteBase several times, but my mistake here was, i entered the absolute serverpath only.

    Again - thanks to all who gave thought to this!
     
    kingofseo likes this.

Share This Page