1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Problem in Embed MP3 Player code

Discussion in 'Styling and Customization Questions' started by Mian Shahid, May 25, 2014.

  1. Mian Shahid

    Mian Shahid Well-Known Member

    Hi, I am trying to add the following in BB Media Code

    <object type="application/x-shockwave-flash" data="dewplayer.swf" width="200" height="20" id="dewplayer" name="dewplayer">
    <param name="movie" value="audio/dewplayer-bubble.swf" />
    <param name="flashvars" value="{$id}" />
    <param name="wmode" value="transparent" />

    but it dose not showing any thing in post where i am putting the following as input

    i think i am doing something wrong but can't figure it out.

    Any idea?
  2. Strong

    Strong Member

    I implemented the browser controlled mp3 player via attachments.

    I edited the template "attached_files" respectively.

    <div class="attachmentInfo pairsJustified">
                            <h6 class="filename"><a href="{xen:link attachments, $attachment}" target="_blank">{$attachment.filename}</a></h6>
                            <dl><dt>{xen:phrase file_size}:</dt> <dd>{xen:number $attachment.file_size, size}</dd></dl>
                            <xen:if is="{$attachment.extension} == 'mp3' ">
                            <audio src="{xen:link attachments, $attachment}" controls></audio></xen:if>
                            <dl><dt>{xen:phrase views}:</dt> <dd>{xen:number $attachment.view_count}</dd></dl>
    The result looks like this:
    Mian Shahid likes this.
  3. Mian Shahid

    Mian Shahid Well-Known Member

    Yes, this was great for attachments, but i am looking a method for third party hosted mp3 files :(

Share This Page