• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Issue with mp3 player

#1
I have a strange issue, I have a mp3 player for attached mp3 files and here is my mp3 player code:

HTML:
<xen:if is="{$attachment.extension} == 'mp3' ">
<!-- player -->
        <script src="http://www.cancionesdelayer.com/audioplayerengine/jquery.js"></script>
    <script src="http://www.cancionesdelayer.com/audioplayerengine/amazingaudioplayer.js"></script>
    <link rel="stylesheet" type="text/css" href="http://www.cancionesdelayer.com/audioplayerengine/initaudioplayer-1.css">
    <script src="http://www.cancionesdelayer.com/audioplayerengine/initaudioplayer-1.js"></script>
    <div id="amazingaudioplayer-1" style="display:block;position:relative;width:100%;height:auto;margin:0px auto 0px;">
        <ul class="amazingaudioplayer-audios" style="display:none;">
            <li data-artist="" data-title="" data-album="" data-info="" data-image="" data-duration="">
                <div class="amazingaudioplayer-source" data-src="{xen:link attachments, $attachment}" data-type="audio/mpeg" />
            </li>
        </ul>
    </div>
<!-- player -->
</xen:if>
When I clic on the LIKE button on a post where a mp3 file is attached I get the following error:

xenforo.js?_v=d2f10c7d:151 Uncaught TypeError: jQuery.easing[jQuery.easing.def] is not a function

Sorry if I didn''t posted this thread in the correct forum.

Thank you all for your help.
 

Brogan

XenForo moderator
Staff member
#2
XenForo already includes jquery so try removing this line as it may be conflicting:
Code:
<script src="http://www.cancionesdelayer.com/audioplayerengine/jquery.js"></script>