1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Private Registration

Discussion in 'Styling and Customization Questions' started by Dean Phillips, Apr 14, 2014.

  1. Dean Phillips

    Dean Phillips New Member

    Hey guys,

    So I've got my wordpress membership site set up on my main domain and forum set up on my sub domain.

    I want to give access to the paid members of the WP membership site only, meaning that that registration link won't be easily found to the public.

    How would I go around doing this?

    The forum will contain personal coaching/support and extra videos from me that back up the membership sites content :)

    Dean
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Hiding the registration link won't stop people from registering.
    To do that you will need to disable registration.

    Otherwise, if you just want to hide/remove the link, edit the templates or use CSS to display:none.
     
  3. Dean Phillips

    Dean Phillips New Member

    Oh right - How would you recommend I make sure only paid members of my membership site get access to the forum?

    Obviously, I don't want unpaid members to be rocking up and getting access to it for free.

    Thanks man!
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

  5. Rigel Kentaurus

    Rigel Kentaurus Well-Known Member

    A quick&dirty way of doing that is leveraging the Captcha mechanism.

    You should be able to theoretically create a Question with a secret answer that you just distribute to your Wordpress premium members. Then, people would only be able to register if they have the passcode.
     
    akhilaniyan likes this.
  6. Dean Phillips

    Dean Phillips New Member

    That's an amazing idea - Thank you so much!!

    I created a q and a cache but it doesn't display as the register cached.

    Could you please tell me how I would go around setting this up?

    Thanks so much,

    Dean
     
  7. Rigel Kentaurus

    Rigel Kentaurus Well-Known Member

    You probably need to enable it in the options
     

Share This Page