1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed "Preview News Feed" reports back "Uncaught Error"

Discussion in 'Resolved Bug Reports' started by JVCode, Jan 20, 2011.

  1. JVCode

    JVCode Well-Known Member

    Trying to preview a feed and it's displaying the following error


    It's giving me this error on all feeds.
  2. Elizabeth

    Elizabeth Well-Known Member

    Only if the feed ends in /feed

    I'm successful if it ends in a number or rss.

    Take that back, there is no rhyme or reason to what worked or didn't work.
  3. Mike

    Mike XenForo Developer Staff Member

    Please provide a feed URL. Also, does the feed work if you save it and import?
  4. Elizabeth

    Elizabeth Well-Known Member

  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I have the same problem. Some feeds work. Others don't.
  6. JVCode

    JVCode Well-Known Member

    Import works fine, it's only previewing the feed that doesn't work.
  7. Mike

    Mike XenForo Developer Staff Member

    Thus far, every feed has worked for me. Can you turn on debug mode and possibly use FireBug to see if there's a better error?
  8. Mike

    Mike XenForo Developer Staff Member

    Ok, got it - PHP 5.2 only.
    Dan likes this.
  9. Mike

    Mike XenForo Developer Staff Member

    library/XenForo/Model/Feed.php, look for:

    			if (!empty($entryData['date_modified']) && is_a($entryData['date_modified'], 'Zend_Date'))
    Replace with:

    			if (!empty($entryData['date_modified']) && $entryData['date_modified'] instanceof Zend_Date)
  10. Dan

    Dan Well-Known Member

    Thats it!
  11. Salty

    Salty Active Member

    Solid fix, thanks
  12. EQnoble

    EQnoble Well-Known Member

    Awesome thanks to Trombones for pointing this out and Mike for being a genius :)
    Everything is working now on rc1 for feeds for me. Cool.
  13. Handyman

    Handyman Member

    Should that be

    /library/XenForo/Model/Feed.php :confused:
  14. ragtek

    ragtek Guest

  15. swatkins

    swatkins Member

    I applied the fix code and the import worked... 4 different threads were started but all returned this error when I clicked on them...

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, webmaster@dieselevents.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    I am at a loss as where to look to fix this problem...

Share This Page