1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Prevent users from posting email addresses

Discussion in 'XenForo Questions and Support' started by NinaMcI, Jul 18, 2016.

  1. NinaMcI

    NinaMcI Active Member

    Hi,
    Is there a way to prevent users from posting their email address in posts and conversations?
    I've tried adding the phrase
    to spam phrases in the ACP spam management options, but this doesn't seem to do the trick.
    Thanks for your help.
     
  2. wang

    wang Well-Known Member

    That will require a custom add on.
     
  3. NinaMcI

    NinaMcI Active Member

    What about using the censoring options?
     
  4. wang

    wang Well-Known Member

    I have not tried it. But the censor will not prevent users from posting email links. It will simply replace the at, which imo is useless.
     
  5. NinaMcI

    NinaMcI Active Member

    OK, thanks for your reply.
     
  6. wang

    wang Well-Known Member

    No problem.
     
  7. adwade

    adwade Active Member

    This is exactly what we do on our board to keep email harvesters from retrieving such, along with using ZB-BLOCK.

    Just make *@* a censored word and you can even define a specific custom replacement for it.(i.e. *@* is replaced with c4h yq, thus John@yahoo.com becomes Johnc4h yqyahoo.com)

    Under Home/Options/Spam Management in the Spam Phrases also enter
    Code:
    *@*
    And Xenforo can automatically throw any such posts into a Moderation Que for you.
     
    Last edited: Jul 19, 2016
  8. teletubbi

    teletubbi Active Member

    Does it affect user tagging?
     
  9. adwade

    adwade Active Member

    I wondered about that as well, but yes Tagging Users works just fine even with the @ symbol censored.

    In AdminCP, under Home/Options/User Alerts I did opt to not check the __Keep @ character with user mentions box, so we don't have any @ symbols showing up on our board.
     
  10. teletubbi

    teletubbi Active Member

    I tried it.
    The censorship replaced it.
    But the email is still underlying.
    So the whole phrase became a email link.
     
  11. adwade

    adwade Active Member

    I can't explain why, but when a user makes a post with their email address in it our board does not show a link.

    For example, here is the content of a post…
    Screen Shot 2016-07-19 at 2.21.09 AM.jpg

    Which appears like this…
    Screen Shot 2016-07-19 at 2.21.34 AM.jpg
    within the thread.

    However, if/when that post is ever opened up and edited then a LINK will appear as you have denoted…
    Screen Shot 2016-07-19 at 2.22.09 AM.jpg

    I have no idea why an original (i.e. untouched) post does not show a LINK, while an edited one will. That's also the reason I mentioned using the custom replacement for the @ symbol when censoring it, as it makes it less obvious what the correct email address is.
     
  12. teletubbi

    teletubbi Active Member

    I made a custom replacement for @.
    But at my board it is always a click able link.
    Doesn't matters if the post is edited or not.
     
  13. NinaMcI

    NinaMcI Active Member

    That has worked just as I wanted.
    Thank you so much for your help :)
     

Share This Page