1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Prefixes Removed When Editing Thread Titles If User Group Doesn't Have Access

Discussion in 'Resolved Bug Reports' started by Amaury, May 5, 2015.

  1. Amaury

    Amaury Well-Known Member

    This might be another design issue or it may be as designed, but we'll see.

    Let's take a prefix from XenForo: Not a Bug. Mike moves a thread to Resolved Bug Reports and prefixes it Not a Bug. However, the reporting user later realizes they made a typo in the title and goes to fix it; after they fix it, the thread is without a prefix because the user group the user is a part of doesn't have access to any of the resolution prefixes and the prefix Not a Bug was therefore removed during the process of changing the thread title.

    Even if we don't have access to certain prefixes and can't change the prefix, whatever prefix is already there should remain in place.
     
    sbj and Liam W like this.
  2. imthebest

    imthebest Formerly Super120

    I Don't Understand Why English Speakers Write The First Letter With Caps :confused:

    Anyway I think that what you have reported might be as designed however I believe it should be changed because as it currently works it looks buggy.
     
  3. Amaury

    Amaury Well-Known Member

    It's a title; that's why. Additionally, unless they are at the beginning or end of the title, prepositions, such as "the," aren't capitalized (there just don't happen to be any in this thread's title). However, let's save that for another time and not derail the thread. :)
     
    imthebest likes this.
  4. Liam W

    Liam W Well-Known Member

    Maru has an affinity for title case for some reason, I only capitalise the correct words...

    I've noticed this, it should be classed as a bug.
     
    imthebest and Amaury like this.
  5. Daniel Hood

    Daniel Hood Well-Known Member

    I think a good fix for this would be to move the logic for checking if a prefix is usable into the datawriter preSave function. This would allow you to only check/remove invalid prefixes if the prefix id has actually be changed.
     
    mjda and Amaury like this.
  6. Mike

    Mike XenForo Developer Staff Member

    Fixed now. The current prefix remains usable regardless of permissions when editing.
     
    Liam W, Amaury, sbj and 1 other person like this.

Share This Page