1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Posts going into moderation

Discussion in 'Troubleshooting and Problems' started by Phases, Dec 4, 2014.

  1. Phases

    Phases Active Member

    We have a forum we allow guests to post into. It was working well. We installed an add-in that a few days later we disabled because of some issues, that was direct relation to posts failing to insert when posted in this forum.

    (multi prefix plugin, and this forum requires a prefix which is set by default already)

    So, we removed this add in. Now the forum works as expected except all posts by guests are going into moderation.

    - I have "Follow forum moderation rules" for unregistered/unconfirmed (usergroup 1) set to Yes.
    - I have " Moderate new threads posted in this forum" unchecked for the node's "Forum Options."
    - I have "Moderate replies posted in this forum" unchecked for the node's "Forum Options."

    I've rebuilt forum cache, and permissions.

    In testing, I did add a test account as Unregistered/Unconfirmed primary usergroup, no secondary, did an analyze permissions, and "Follow forum moderation rules" was set to yes. Tried to post, and it worked fine.

    I've also set $config['enableListeners'] = false; for my IP and tested, no change.

    The only thing I can think (of why it works with test account but not true guest) is the rule being applied to people in usergroup 1, as opposed to people with no usergroup association at all - but all the googling and searching here I've done would indicate that shouldn't be the case and that I should be able to get it working the way I want.

    I'm 99.9% sure we had it working when we launched, but there is some chance I am wrong.

    Am I missing something? Or is there another way I can test some stuff to try to pinpoint?

    Edit, Answered: Posts going into moderation

    ("Maximum Messages to Check for Spam" was set to 1, and the phrases was left blank - so.. triggering for all?)
    Last edited: Dec 4, 2014
  2. Brogan

    Brogan XenForo Moderator Staff Member

    It's possible that one of the add-ons has caused a problem.

    Try changing the permission for the unregistered group to not set, saving, changing it to allow and saving again.
  3. Phases

    Phases Active Member

    No change..
  4. Jeremy

    Jeremy Well-Known Member

    Are you saying that they are permitted to post but the posts end up in Moderation versus being publicly visible to start off with?
  5. Phases

    Phases Active Member

    Yeah it posts successfully and redirects them to the node and the message "Your message has been submitted and will be displayed pending approval by a moderator." appears.

    Appreciate the attention, guys.
  6. Brogan

    Brogan XenForo Moderator Staff Member

    It may be the spam settings which are triggering it.

    Try disabling the various services (spam phrases, Akismet) and see if that helps.
    Phases likes this.
  7. Phases

    Phases Active Member

    You're the man. "Maximum Messages to Check for Spam" was set to 1. I didn't have any phrases in there though. Does no phrases inserted default to flagging anything? I will test that later, it is of no consequence at this point, just curiuos.

    Thank you (both)!
  8. Brogan

    Brogan XenForo Moderator Staff Member

    Do you have Akismet enabled?

    If there are no spam phrases entered then the value should be irrelevant.

    Although I haven't checked the code to confirm that is the case - it may be that all messages are checked if the spam phrases are empty.
  9. Phases

    Phases Active Member

    Yeah it's in the Akismet settings where that is, and there is a API key put in. I changed it to 0 and all is well. But yeah again there are no phrases entered.

    I could see it being useful for it to work that way so it wouldn't surprise me if it's the case, though I'd suggest some verbiage to indicate that.

    Thanks again,
  10. Brogan

    Brogan XenForo Moderator Staff Member

    Set it to 1 and temporarily disable Akismet.

    The post should go through then.

    The value applies to the spam phrases and Akismet.
    Phases likes this.

Share This Page