• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Post Limit Per Node by AddonsLab 1.6.0

No permission to download

AddonsLab

Well-known member
#21
How do I limit threads and replies for a user on a specific forum, but allow mods to bypass this limit?
Just configure the limits for that particular forum. You can access the permissions page on Node List, using the Permissions link on the right side. By default, the number of replies/threads created by a user is counted board-wide, meaning if you put a limit of 1 thread/per hour in one node, and user has already created another thread in another node, they will not be able to post a thread in the configured node. You can make the system to count the threads/posts in that particular node only by setting the node ID in product's settings page.

Just let us know if you still have any questions.

Thank you!
 

Temery

Active member
#22
Just configure the limits for that particular forum. You can access the permissions page on Node List, using the Permissions link on the right side. By default, the number of replies/threads created by a user is counted board-wide, meaning if you put a limit of 1 thread/per hour in one node, and user has already created another thread in another node, they will not be able to post a thread in the configured node. You can make the system to count the threads/posts in that particular node only by setting the node ID in product's settings page.

Just let us know if you still have any questions.

Thank you!
Can I exempt moderators from the limit set for a specific board?
 

AddonsLab

Well-known member
#23
Can I exempt moderators from the limit set for a specific board?
Yes, the limits are group/node specific, so you should simply set the limits for usergroups that are affected (for example for registered usergroups), and leave the others (for example moderators, administrators) without any setup. In this case, the users in these usergroups will not be affected by the limits.

Thank you!
 

Temery

Active member
#24
Yes, the limits are group/node specific, so you should simply set the limits for usergroups that are affected (for example for registered usergroups), and leave the others (for example moderators, administrators) without any setup. In this case, the users in these usergroups will not be affected by the limits.

Thank you!
I'm still not seeing. This doesn't seem to be any different than setting a posting limit site-wide. I have a single forum I'd like to limit posts for specific users.
 

AddonsLab

Well-known member
#25
I'm still not seeing. This doesn't seem to be any different than setting a posting limit site-wide. I have a single forum I'd like to limit posts for specific users.
The settings page is located at https://site.com/admin.php?options/list/alpl_general It looks like this:

Screenshot 2017-05-24 18.39.49.png

Here you need to specify the node ID where you want to put the limits. And in the Permissions page for the same node you should set the actual limits.

I hope this clarifies. Let us know if you still have any issues.

Thank you!
 
#26
Does work when using auto software for posting new thread? One more Suggestions, Please Can add User Group Permissions setting are Seperate? Or Permissions and node are in option page ? Not mixing with Forum Permissions. Its impossible to easily find out the option, when we have lot of User Group Permissions option. Also its not good idea to mixing with xF core Group Permissions.
 

AddonsLab

Well-known member
#27
Does work when using auto software for posting new thread? One more Suggestions, Please Can add User Group Permissions setting are Seperate? Or Permissions are in option page ? Not mixing with Forum Permissions. Its impossible to easily find out the option, when we have lot of User Group Permissions option. Also its not good idea to mixing with xF core Group Permissions.
It depends on software you are using and it is up to that software to decide, if it considers usergroup permissions or no. The products hooks in user's action during thread/post creation, so it is less likely that a automated software will use this route, so most likely it will not consider the limits.

Thank you for the suggestion. Unfortunately, we can't have this setting on a separate page, and having the settings in usergroup/forum permissions makes sense, as any other limits, for example, the number of attachments per thread etc. are also on that page. Creating a separate page for these settings would be too much time consuming for us and we can't consider it for this product.

Thank you!
 
#28
I just upgraded to the latest version and the addon doesn't appear to be working as we need it now.

Registered users usergroup permissions is to create unlimited threads in unlimited time (Because we don't want to place a restriction on most of the nodes)

On our classifieds node, we have registered users able to create 1 thread every 72 hours. However, the unlimited in the usergroup permission is overriding the 1/72 limit on the node permission. This doesn't work for us because now users can create unlimited threads in our classified node.
 

AddonsLab

Well-known member
#29
Checked this and found the issue. One of older versions of the product forces "unlimited" option for all usergroups to be selected for all usergroups, as it was considering values "0" as "not allowed to post at all". This logic changed later, but there was a bug there considering 0 as no threads. Now this is fixed and the installation code is updated to remove the hard-coded "unlimited" values.

We will release a new version now with the fix. Just upgrading should fix the problem. If you still see it, please check general usergroup permissions and make sure all limits are put to 0.

Thank you!
 

AddonsLab

Well-known member
#30
AddonsLab updated Post Limit Per Node by AddonsLab with a new update entry:

Fixed node-based permission configuration conflict

Hello, everyone!

This is a bug fix release of Post Limit Per Node product, that fixes node-based permission configuration conflict when the permissions on usergroups are put to "unlimited". To have unlimited permissions you should just leave the limits on permission level to 0, and configure the permissions per-node basis.

To install the fix you need to re-upload product files and re-import product XML file.

Thank you!
Read the rest of this update entry...
 

RoldanLT

Well-known member
#31
Can you please change the time limit from hours to just minutes for threads and seconds for post??
An hour is a bit too much for me.
 

AddonsLab

Well-known member
#32
Can you please change the time limit from hours to just minutes for threads and seconds for post??
An hour is a bit too much for me.
I see. Count per hour seems to work for most of the users, however, meaning they have to use very large numbers to express the hours in minutes and especially in seconds. Also, such update would break the backward-compatibility for everyone, who does not want actually want the change and they would need to update their usergroup settings (possibly for several usergroups). We will try to think of a way to make it backward-compatible. Once we come up with a solution we will release the update here. You can expect the update in coming 2-3 days.

Thank you!
 

AddonsLab

Well-known member
#36
Hello, @beepdotpw

I am not completely sure what is the problem, but it should be related to usage of permissions and the way permissions override each other. It is likely, that you have the "unlimited" option set on usergroup level, and node-level permission does not override it. So, you can check what the permissions for that user in their usergoups, and set to "not set" instead of "unlimited". In this case node-based permission will be applied. This is how the permission system works in XenForo in general.

Just let us know if there are other problems.

Thank you!
 
#38
[QUOTE = "AddonsLab, poste: 1174828, membre: 137157"] Bonjour, [USER = 161455] @beepdotpw [/ USER]

Je ne suis pas tout à fait sûr de quel problème, mais cela devrait être lié à l'utilisation des autorisations et à la façon dont les autorisations s'écoulent mutuellement. Il est probable que vous disposez de l'option «illimitée» définie sur le niveau du groupe d'utilisateurs, et l'autorisation du niveau du noeud ne l'empêche pas. Ainsi, vous pouvez vérifier quelles sont les autorisations pour cet utilisateur dans leurs usergoups et définir "non défini" au lieu de "illimité". Dans ce cas, l'autorisation basée sur le noeud sera appliquée. C'est ainsi que le système d'autorisation fonctionne dans XenForo en général.

Dites-nous s'il y a d'autres problèmes.

Merci! [/ QUOTE]

https://gyazo.com/dfac4df80ce5dad7b2a8c4a5b8ba452a hello thanks for your help is not the option undefined? in global permissions
 

AddonsLab

Well-known member
#39
[QUOTE = "AddonsLab, poste: 1174828, membre: 137157"] Bonjour, [USER = 161455] @beepdotpw [/ USER]

Je ne suis pas tout à fait sûr de quel problème, mais cela devrait être lié à l'utilisation des autorisations et à la façon dont les autorisations s'écoulent mutuellement. Il est probable que vous disposez de l'option «illimitée» définie sur le niveau du groupe d'utilisateurs, et l'autorisation du niveau du noeud ne l'empêche pas. Ainsi, vous pouvez vérifier quelles sont les autorisations pour cet utilisateur dans leurs usergoups et définir "non défini" au lieu de "illimité". Dans ce cas, l'autorisation basée sur le noeud sera appliquée. C'est ainsi que le système d'autorisation fonctionne dans XenForo en général.

Dites-nous s'il y a d'autres problèmes.

Merci! [/ QUOTE]

https://gyazo.com/dfac4df80ce5dad7b2a8c4a5b8ba452a hello thanks for your help is not the option undefined? in global permissions
In some earlier versions of our add-on the "unlimited" option was hard-coded at installation time, so the issue may be caused by that, but the latest version should have solved it. Please check your Usergroups, and just set to "Not Set" permissions for all of them which you didn't configure yourself, this should solve the problem.

Thank you!
 
#40
[QUOTE = "AddonsLab, poste: 1174832, membre: 137157"] Dans certaines versions antérieures de notre add-on, l'option "illimitée" a été codée en dur à l'heure d'installation, de sorte que le problème peut être causé par cela, mais la dernière version devrait l'avoir résolu. Vérifiez vos groupes d'utilisateurs et définissez les autorisations "Not Set" pour tous ceux que vous ne vous avez pas configurés, cela devrait résoudre le problème.

Merci! [/ QUOTE]

merci de le voir ou pas défini? J'ai la dernière version