1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not a Bug Possible memcache bug

Discussion in 'Resolved Bug Reports' started by xnetco, Nov 13, 2013.

  1. xnetco

    xnetco Member


    I have a potential bug in memcache. Memcache seems to be working quite well although this error is appearing occasionally. I wondered if this was connected to the size of the packet. Would appreciate some feedback?


    ErrorException: Memcache::get() [<a href='memcache.get'>memcache.get</a>]: Server (tcp 11211) failed with: Connection timed out (110) - library/Zend/Cache/Backend/Memcached.php:180
    Generated By: Unknown Account, Yesterday at 8:58 PM
    Stack Trace
    #0 [internal function]: XenForo_Application::handlePhpError(8, 'Memcache::get()...', '/home/sites/avf...', 180, Array)
    #1 /home/sites/avforums/public_html/library/Zend/Cache/Backend/Memcached.php(180): Memcache->get('xf_data_options')
    #2 /home/sites/avforums/public_html/library/Zend/Cache/Core.php(303): Zend_Cache_Backend_Memcached->load('xf_data_options', false)
    #3 /home/sites/avforums/public_html/library/XenForo/Model/DataRegistry.php(87): Zend_Cache_Core->load('data_options')
    #4 /home/sites/avforums/public_html/library/XenForo/Dependencies/Abstract.php(144): XenForo_Model_DataRegistry->getMulti(Array)
    #5 /home/sites/avforums/public_html/library/XenForo/FrontController.php(127): XenForo_Dependencies_Abstract->preLoadData()
    #6 /home/sites/avforums/public_html/index.php(13): XenForo_FrontController->run()
    #7 {main}
  2. Mike

    Mike XenForo Developer Staff Member

    This is just an indication that the connection to your Memcache server failed. No different than the connection to MySQL (or elasticsearch) failing.
  3. xnetco

    xnetco Member

    Hi Mike,

    Thanks for coming back to me.

    That is what I originally suspected but the connection issues have been resolved. The only memcache related issues issues now seem to mention xf_data_options. Could this be to do with the packet size?


  4. Mike

    Mike XenForo Developer Staff Member

    Unlikely - it's just the first call to Memache.
  5. xnetco

    xnetco Member

    Thanks. I'll do some more investigation.

Share This Page