• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Plugin Field only works in 1 location

Status
Not open for further replies.
#1
Hey,

NOTE: I have no coding experience, this could be dumb to ask :p

I know this is addon/mod talk but it might serve as a good tutorial. Not after multiple locations, just to move it. Though knowing how would be good.

So I currently have 2 plugins installed:

https://xenforo.com/community/resources/most-online-users.218/
https://xenforo.com/community/resources/forum-statistics-pixelexit-com.2577/

The online users plugin works fine, adding the display to the forum stats on the sidebar:



So I thought hey, I know what would work.. Let me add this to the footer stats instead and see what happens!



Lets clean it up a little for looks:



Not working.. I thought it was the div names, I went though all the mod files to look for something obvious.. Nothing I can see.

Is there some hook field I am missing or some database edit I have to make?

Thanks for any help!

Edit: Live Demo http://lets-flip.com
 
Last edited:

Brogan

XenForo moderator
Staff member
#2
The data may not be exposed to that template, and likely isn't.

You would need to post in the resource thread for any specific support related to it.
 

Brogan

XenForo moderator
Staff member
#5
It means the value for the online users is not available in the template you have added the code to.
 

Steve F

Well-known member
#6
The data for the most online users is probably only sent to the sidebar stats template. So trying to add it anywhere else would show as null (zero).
 
#7
The data for the most online users is probably only sent to the sidebar stats template. So trying to add it anywhere would show as null (zero).
Hey Steve, just noticed its your plugin haha :p .. Next question of course, so if it needs the data exposed.. how/where would I do that?
 
Status
Not open for further replies.