1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Phrase cannot be saved

Discussion in 'Resolved Bug Reports' started by Teascu Dorin, Jun 19, 2013.

  1. Teascu Dorin

    Teascu Dorin Active Member

    There is a phrase in 1.2.0 Beta that cannot be saved:

    title: a_moment_ago
    main value: A moment ago
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    What do you mean by it can't be saved?

    It's a default phrase.

    What is happening when you try to save it?
     
  3. Teascu Dorin

    Teascu Dorin Active Member

    I am translating the phrases and when I save it it remains on the same page like I'm using Save & Reload but I saved and it keeps appearing on Outdated Phrases.
    There are more than that one: a_moment_ago, day_friday, day_friday_short, day_monday and more...
     
  4. Teascu Dorin

    Teascu Dorin Active Member

    P.S. Here is the error from the logs from one of the phrases on saving:

    HTML:
    Server Error Log
    Error Info
    Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Lock wait timeout exceeded; try restarting transaction - library/Zend/Db/Statement/Mysqli.php:214
    Generated By: Teascu Dorin, 28 minutes ago
    Stack Trace
    #0 /home/*********/html/xen1dev/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
    #1 /home/*********/html/xen1dev/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
    #2 /home/*********/html/xen1dev/library/XenForo/Model/Template.php(1616): Zend_Db_Adapter_Abstract->query('????INSERT INTO...', Array)
    #3 /home/*********/html/xen1dev/library/XenForo/Model/Template.php(1542): XenForo_Model_Template->_insertCompiledTemplateRecord(18, 1, 'PAGE_CONTAINER', '$__output = '';...')
    #4 /home/*********/html/xen1dev/library/XenForo/Model/Template.php(1417): XenForo_Model_Template->compileAndInsertParsedTemplate(708, Array, 'PAGE_CONTAINER', 18)
    #5 /home/*********/html/xen1dev/library/XenForo/Model/Template.php(1284): XenForo_Model_Template->compileTemplateInStyleTree(Array)
    #6 /home/*********/html/xen1dev/library/XenForo/Model/Template.php(1493): XenForo_Model_Template->compileMappedTemplatesInStyleTree(Array)
    #7 /home/*********/html/xen1dev/library/XenForo/DataWriter/Phrase.php(348): XenForo_Model_Template->compileTemplatesThatIncludePhrase('day_monday')
    #8 /home/*********/html/xen1dev/library/XenForo/DataWriter/Phrase.php(254): XenForo_DataWriter_Phrase->_recompileTemplatesIncludingPhrase()
    #9 /home/*********/html/xen1dev/library/XenForo/DataWriter.php(1392): XenForo_DataWriter_Phrase->_postSave()
    #10 /home/*********/html/xen1dev/library/XenForo/ControllerAdmin/Phrase.php(179): XenForo_DataWriter->save()
    #11 /home/*********/html/xen1dev/library/XenForo/FrontController.php(335): XenForo_ControllerAdmin_Phrase->actionSave()
    #12 /home/*********/html/xen1dev/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #13 /home/*********/html/xen1dev/admin.php(13): XenForo_FrontController->run()
    #14 {main}
    Request State
    array(3) {
      ["url"] => string(55) "https://www.rostyles.com/xen1dev/admin.php?phrases/save"
      ["_GET"] => array(1) {
        ["phrases/save"] => string(0) ""
      }
      ["_POST"] => array(9) {
        ["title"] => string(10) "day_monday"
        ["phrase_text"] => string(4) "Luni"
        ["addon_id"] => string(7) "XenForo"
        ["phrase_id"] => string(4) "5266"
        ["language_id"] => string(1) "2"
        ["_xfToken"] => string(8) "********"
        ["_xfRequestUri"] => string(47) "/xen1dev/admin.php?phrases/day_monday.5266/edit"
        ["_xfNoRedirect"] => string(1) "1"
        ["_xfResponseType"] => string(4) "json"
      }
    }
    
     
  5. Mike

    Mike XenForo Developer Staff Member

    That may be a temporary server glitch or an indication that something is completely stuck in the server. It should go away.
     
  6. Teascu Dorin

    Teascu Dorin Active Member

    For more then 10 different phrases and between them some other were saved without problems?
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  8. Teascu Dorin

    Teascu Dorin Active Member

    The wait time is set at 7200 and I believe is more then enough!
     
  9. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Then there is a row lock exceeding 7200 seconds.

    Check the mysql process list. Or just restart the server. That will free it up, whatever is holding the lock.
     
  10. Teascu Dorin

    Teascu Dorin Active Member

  11. Tracy Perry

    Tracy Perry Well-Known Member

    And you won't... php.ini controls PHP's variables. The one that controls mySQL is called (normally) my.cnf, and is normally located at /etc/mysql.
     
  12. Teascu Dorin

    Teascu Dorin Active Member

    That is bad because I don't have access to that. What should I ask the hosting to do?
     
  13. Teascu Dorin

    Teascu Dorin Active Member

    Only a fresh install of the software fixed the problem. For me is not a problem as is just a demo/testing board not my live forum.
     
  14. Allan

    Allan Well-Known Member

    Same problem for french translation, with 5 or 6 expressions.
     
  15. Allan

    Allan Well-Known Member

    I find it very hard to translate, many expressions don't save. (I said that I am on a dedicated server)
     
  16. Teascu Dorin

    Teascu Dorin Active Member

    I believe that the update from 1.1.5 to 1.2.0b1 is not made "perfectly" not a server problem.
     
  17. Alluidh

    Alluidh Well-Known Member

    Maybe this should be moved to "XenForo Bug Reports"
     
  18. Teascu Dorin

    Teascu Dorin Active Member

    Yes, indeed. After I posted the message I believed that should be posted as bug.
     
  19. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Mike does have an open ticket for this problem. He will be debugging it to figure out what is going on.
     
  20. Alluidh

    Alluidh Well-Known Member

    Thats OK, but it is a bug and should be moved before the next translator opens a new bug report for this :D
     

Share This Page