XF 1.5 PHP 5.6 Default settings

Brogan

XenForo moderator
Staff member
#2
We recommend that all options are enabled.

Disabling options may cause issues in the future if they are ever used.
 

Robust

Well-known member
#9
I think a few of those can provide a bit more than you need and overwhelm you. For a minimum, recommended installation, personally I'd do:
  • bcmath
  • gd
  • imagick
  • json
  • mbstring
  • mcrypt
  • mysqli
  • (or mysqlnd if using mariadb)
  • zip
+ any others you may need for caching etc. (e.g. memcached, redis, etc.). If more are added to requirements, then you simply just enable them in your cPanel, or if using a standard Linux approach, install them with a package manager or download them and recompile PHP.
 
Top