1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PHP 5.6.0 released

Discussion in 'Server Configuration and Hosting' started by RoldanLT, Aug 28, 2014.

  1. RoldanLT

    RoldanLT Well-Known Member

    The PHP Development Team announces the immediate availability of PHP 5.6.0. This new version release comes with new features, some backward incompatible changes and many improvements.

    The main features of PHP 5.6.0 include:

    For a full list of new features, you may read our migration guide new features chapter.

    PHP 5.6.0 also introduces changes that affect compatibility:

    • Array keys won't be overwritten when defining an array as a property of a class via an array literal.
    • json_decode() is more strict in JSON syntax parsing.
    • Stream wrappers now verify peer certificates and host names by default when using SSL/TLS.
    • GMP resources are now objects.
    • Mcrypt functions now require valid keys and IVs.
    For users upgrading from PHP 5.5, a full migration guide is available, detailing the changes between 5.5 and 5.6.0.

    For source downloads of PHP 5.6.0, please visit our downloads page. Windows binaries can be found onwindows.php.net/download/. The full list of changes is available in the ChangeLog.
    eva2000 and whynot like this.
  2. Tracy Perry

    Tracy Perry Well-Known Member

    And time to see what breaks with it on the CentOS 6.5 box. Busy doing a compile of it now.
  3. BamaStangGuy

    BamaStangGuy Well-Known Member

  4. Tracy Perry

    Tracy Perry Well-Known Member

    You using GeoIP on your site (for PHP?). I get a compile error when I do a pecl install geoip.


    Ended up having to remove the PECL that was installed under 5.5.16 and install again (after remembering how to change the PEAR temp directory)... it's working now.

    So far I haven't noticed any other problems.
    Last edited: Aug 28, 2014
  5. BamaStangGuy

    BamaStangGuy Well-Known Member

    Wasn't using GeoIP.
  6. Tracy Perry

    Tracy Perry Well-Known Member

    Well, another problem I've just noticed.... I use postfix/dovecot on my server to send/receive my mail. After the upgrade to 5.6 using the bounce feature of XenForo results in a failed logon with imap (was working before the upgrade). Am in the process of now recompiling 5.5.16 to use and see if that solves the problem.
  7. Tracy Perry

    Tracy Perry Well-Known Member

    And it's confirmed... I regressed back to PHP 5.5.16 and postfix/dovecot works just fine for the IMAP connection from XenForo.

    Aug 28 07:46:51 poomba dovecot: imap-login: Login: user=<nsl_bounce>, method=PLAIN, rip=XXX.XXX.XXX.XXX, lip=XXX.XXX.XXX.XXX, mpid=29800, TLS
    Aug 28 07:46:51 poomba dovecot: imap(nsl_bounce): Disconnected: Logged out bytes=49/697
    And the same on 5.6
    Aug 28 07:18:51 poomba dovecot: imap-login: Disconnected (no auth attempts): rip=XXX.XXX.XXX.XXX, lip=XXX.XXX.XXX.XXX, TLS handshaking: SSL_accept() failed: error:14094418:SSL routines:SSL3_READ_BYTES:tlsv1 alert unknown ca: SSL alert number 48
    @Mike or @Kier, would the new changes in PHP 5.6 possibly cause a problem with this (PHP is compiled via Centmin Mod).
  8. Mike

    Mike XenForo Developer Staff Member

    That would appear to be related to the fact that 5.6 verifies certificates by default and can't verify your IMAP server's cert.
    eva2000 likes this.
  9. eva2000

    eva2000 Well-Known Member

    For major PHP version updates, I usually recompile all extra PHP extensions to prevent problems like this. That is what Centmin Mod PHP-FPM upgrade menu does. But PHP GeoIP isn't a default extension for Centmin Mod PHP-FPM - might have to add it to next release :)

    probably what @Mike said, as I updated my forums to PHP 5.6.0 without problems https://community.centminmod.com/th...upgraded-to-php-5-6-0-ga-stable-release.1220/ :)
  10. Tracy Perry

    Tracy Perry Well-Known Member

    I was actually surprised it wasn't already there. :p

    Due to using a self-signed certificate is what is causing the problem. You have to utilize the
    cafile (possibly)
    in the php.ini file.

    The documentation is not as detailed as I would prefer. I solved the problem by just using dovecot on IMAP port 143 and blocking all access to ports 993, 995, 143, 110 from any IP other than those listed in my CSF allow file. Works fine now.... but not the way I would rather it to do. But, I have time to play with it now.
  11. eva2000

    eva2000 Well-Known Member

  12. Tracy Perry

    Tracy Perry Well-Known Member

  13. RoldanLT

    RoldanLT Well-Known Member

    Flawless Upgrade, Thanks to @eva2000 for his guidance :)
    eva2000 likes this.
  14. Lexy

    Lexy Active Member

    i run 5.4.30 can i ask my host to update on 5.6 it is safe, also run CENTOS 6.5 x86_64 virtuozzo – server
  15. DroidOne

    DroidOne Well-Known Member

    How does Xenforo 1.4 RC2 run on PHP 5.6?
  16. Tracy Perry

    Tracy Perry Well-Known Member

    Better than it does on the earlier versions. :D
    DroidOne and Alfa1 like this.
  17. Moshe1010

    Moshe1010 Well-Known Member

    Any noticeable performance differences from 5.5?
  18. Andy.N

    Andy.N Well-Known Member

    smooth like butter.
    I have it running on my live site and there is no problem at all.
    DroidOne likes this.
  19. Tracy Perry

    Tracy Perry Well-Known Member

    For me, it seems a little quicker.
    DroidOne likes this.
  20. MattW

    MattW Well-Known Member

    Same, especially running @Floren 's version.
    DroidOne likes this.

Share This Page