• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 PHP 5.4

Craig

Active member
#1
Good morning to all.

I am currently running Xf 1.2.2. I was told I should upgrade my server to PHP 5.4 (currently running 5.2.17) prior to upgrading to XenForo 1.4.

I am wondering if what I have been told is good advise or not.

Thanks in advance.
 

Brogan

XenForo moderator
Staff member
#2
Upgrading to a later/latest version of PHP is generally a good idea.

XF2 will require a higher version of PHP than 5.2 so it will definitely be required then.
PHP Requirements

The PHP requirements of XenForo 2.0 will definitely be increasing, primarily because we want to take advantage of technologies that newer versions of PHP now offer. The current target is a minimum of PHP 5.4.